HDU-5538 House Building(暴力)

House Building

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 262144/262144K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 18
Problem Description
Have you ever played the video game Minecraft? This game has been one of the world's most popular game in recent years. The world of Minecraft is made up of lots of $1 \times 1 \times 1$ blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material such as brick or concrete in this game.


Figure 1: A typical world in Minecraft.


Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it's really a lovely place to build houses on it. Nyanko-san decided to build on a $n \times m$ big flat ground, so he drew a blueprint of his house, and found some building materials to build.

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.

There are $n$ rows and $m$ columns on the ground, an intersection of a row and a column is a $1 \times 1$ square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san's blueprint can be represented as an integer array $c_{i,j} (1\le i \le n, 1 \le j \le m)$. Which $c_{i,j}$ indicates the height of his house on the square of $i$-th row and $j$-th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san's house(exclude the face adjacent to the ground).
 

Input
The first line contains an integer $T$ indicating the total number of test cases. First line of each test case is a line with two integers $n,m$. The $n$ lines that follow describe the array of Nyanko-san's blueprint, the $i$-th of these lines has $m$ integers $c_{i,1}, c_{i,2}, ..., c_{i,m}$, separated by a single space. $1 \le T \le 50$ $1 \le n,m \le 50$ $0 \le c_{i,j} \le 1000$
 

Output
For each test case, please output the number of glass units you need to collect to meet Nyanko-san's requirement in one line.
 

Sample Input
  
  
2 3 3 1 0 0 3 1 2 1 1 0 3 3 1 0 1 0 0 0 1 0 1
 

Sample Output
  
  
30 20 [center][img]../../data/images/C646-1012-2.jpg[/img][/center] [center][b]Figure 2: A top view and side view image for sample test case 1.[/b][/center]
 

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

传送门:http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1003&ojid=0&cid=11108&hide=0

题意:给出一个3维立体图形,要求给他的表面涂上颜色(底面不用涂),要求求出所需涂色的面积

题解:先把所有块的侧面(4个面)涂色,然后把重复的面积去掉,最后加上顶面的面积

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#define FIN freopen("in.txt","r",stdin)
#define eps 1e-9
using namespace std;
int mp[55][55],cnt,n,m;
int to[][2]={0,1,0,-1,1,0,-1,0};
int main(){
    int T;
  //  FIN;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        int top=0;
        cnt=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++){
                scanf("%d",&mp[i][j]);
                top=max(top,mp[i][j]);
                if(mp[i][j]) cnt++;
                cnt+=mp[i][j]*4;
            }
        for(int x=0;x<n;x++){
            for(int y=0;y<m;y++){
                for(int i=0;i<4;i++){
                    int xx=x+to[i][0],yy=y+to[i][1];
                    if(xx<0||yy<0||xx>=n||yy>=m) continue;
                    cnt-=min(mp[x][y],mp[xx][yy]);
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值