CSU-2037 Mars(字符串哈希)

2037: Mars

Submit Page      Summary      Time Limit: 3 Sec       Memory Limit: 512 Mb       Submitted: 103       Solved: 34    

Description

A new form of life is recently discovered on Mars. Every alien has a DNA, that is a string with an alphabet of only two, rather than four, letters. Hence we can show the DNA of a Mars alien by a binary string. Let s be an alien DNA of length n. There are q regions in the DNA specified as genes. A gene located at [a, b] is a substring of the DNA, containing characters from position a to position b, inclusive (1 ⩽ a ⩽ b ⩽ n). A gene might overlap with or be inside the other genes. During the life of a Mars alien, each gene is copied billions of times: a protein binds to the start of the gene, and copies the gene from start to the end. But this process is not error-free, and might produce mutations. In each mutation, a 0 in the gene is copied as 1, or vice-versa. A mutated copy does not match the gene, but might match a (possibly overlapping) substring in another position of the DNA. For instance, assume that s = 001011111 and a gene is located at [3, 6]. Hence, the gene string is 1011. A copy of this gene can be 1111, which is mutated at the second letter. Although 1111 does not match the original [3, 6] substring in the DNA, it matches [5, 8]. A mutated copy of a gene is called degenerate if it does not appear in any place of the whole DNA. Hence, 1010, a copy of the same gene having one mutation at the fourth letter, is degenerate, but 1111 is not. Your task is to find, for each gene, the minimum number of mutations that can result in a degenerate copy of that gene.

Input

There are multiple test cases in the input. The first line of each test case contains two integers n and q (2 ⩽ n ⩽ 10, 000 and 1 ⩽ q ⩽ 1000). The next line contains a binary string s of length n. Each of the next q lines contains the location [a, b] of a gene, in the form of two space-separated integers a and b (1 ⩽ a ⩽ b ⩽ n). The input terminates with a line containing “0 0” that should not be processed.

Output

For each gene, print the minimum number of mutations that can result in a degenerate copy. If no set of mutations applied on a gene can result in a degenerate copy, print “Impossible” instead.

Sample Input

4 3
0110
1 2
2 3
1 1
0 0

Sample Output

1
2
Impossible

Hint

Source

ATRC2017


#include <cstdio>
#include<map>
#include<algorithm>
#include<unordered_map>
#include<iostream>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define x first
#define y second
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int, int> PII;
typedef pair<int, LL>PIL;
const int MX = 1e4 + 5;
const ULL PA = 131;

struct node {
    int l, r, len, id;
    bool operator< (const node& _A) const {
        return len < _A.len;
    }
} a[MX];

char str[MX];
int n, m, ans[MX];
LL C[MX];
ULL H[MX], P[MX];
unordered_map<ULL, bool> mp;


void Hash() {
    H[0] = n;
    P[0] = 1;
    for (int i = 1; i <= n; i++) {
        H[i] = H[i - 1] * PA + str[i] - '0' + 1;
        P[i] = P[i - 1] * PA;
    }
}

ULL code (int l, int r) {
    return H[r] - H[l - 1] * P[r - l + 1];
}

void pre_solve (int len) {
    mp.clear();
    C[0] = 1;
    for (int i = 1; i <= len; i++) C[i] = C[i - 1] * (len - i + 1) / i;
    for (int i = 1; i + len - 1 <= n; i++) {
        mp[code (i, i + len - 1)] = 1;
    }
}

bool dfs (int l, int r, int cnt, ULL c) {
    if (cnt == 0) return mp[c];
    for (int i = l; i <= r; i++) {
        int tmp = str[i] - '0';
        ULL t = c - P[r - i] * (1 + tmp) + P[r - i] * (2 - tmp);
        if (!dfs (i + 1, r, cnt - 1, t) ) return 0;
    }
    return 1;
}

int main() {
    //freopen ("in.txt", "r", stdin);
    while (~scanf ("%d%d", &n, &m), n || m) {
        scanf ("%s", str + 1);
        Hash();
        for (int i = 1; i <= m; i++) scanf ("%d%d", &a[i].l, &a[i].r), a[i].len = a[i].r - a[i].l + 1, a[i].id = i, ans[i] = -1;
        sort (a + 1, a + m + 1);
        for (int i = 1; i <= m; i++) {
            if (a[i].len != a[i - 1].len) pre_solve (a[i].len);
            LL cnt = 1;
            ULL c = code (a[i].l, a[i].r);
            for (int len = 1; len <= a[i].len; len++) {
                if (!dfs (a[i].l, a[i].r, len, c) ) {ans[a[i].id] = len; break;}
                if (len == a[i].len) break;
                cnt += C[len];
                if (cnt + C[len + 1] > mp.size() ) ans[a[i].id] = len + 1;
            }
        }
        for (int i = 1; i <= m; i++) {
            if (ans[i] == -1) printf ("Impossible\n");
            else printf ("%d\n", ans[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值