How Many Answers Are Wrong(并查集)

原题链接
How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5958 Accepted Submission(s): 2252

Problem Description
TT and FF are … friends. Uh… very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

BoringBoringa very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output
A single line with a integer denotes how many answers are wrong.

Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output
1

Source
2009 Multi-University Training Contest 13 - Host by HIT

//http://acm.hdu.edu.cn/showproblem.php?pid=3038
//这个并查集就是把一个个区间化成每个区间的起点i和起点的最终父亲F[i]他们这一段的总和,中间的值存储为sum[i],他们的父亲不一定要比他大,中间的值也不一定是正的
//并查集的每一个已知的区间就可以通过这这样的方式表示出来
//想得到一个新的区间的方法就是找到一个完全包含小区间了n的大区间m,那么新的区间就是大区间与小区间的差|---new---|-n-|
//                                                                                  |------m------|
#include <cstdio>
#include <cstring>
using namespace std;
int sum[200005],F[200005];//F[i]表示i的父亲,sum[i]表示i这个点到F[i]这个点之间的和
int f(int x){
        if(x!=F[x]){
                int pre=F[x];
                F[x]=f(F[x]);//开始初始化的时候他的父亲就是他自己,但是后面他的父亲会变化,所以要找到他自己真正的父亲
                sum[x]+=sum[pre];//之所以在这这里加就是等所有的部分都更新完后在这里就一次性更新就好了
        }
        return F[x];
}
int main(){
        int n,m;
        while(scanf("%d%d",&n,&m)==2){
                int res=0;
                memset(sum,0,sizeof(sum));
                for(int i=0;i<=n;i++)
                        F[i]=i;
                while(m--){
                        int a,b,s;
                        scanf("%d%d%d",&a,&b,&s);
                        a--;//对于A~B之间的和是S,其实可以理解成B比A-1大S;
                        int pa=f(a);
                        int pb=f(b);
                        if(pa==pb){//如果都是同样的父亲那么就要进行差值的比较了
                                if(sum[b]-sum[a]!=s) res++;//他们之间的关系就是b<a<=pa;
                        }
                        else{//如果不是同样的父亲,
                                F[pb]=pa;
                                sum[pb]=s+sum[a]-sum[b];//他们之间的关系就是b<a<=pa,b<pb<pa,同时b~a,a~pa,b~pb都已知,所以只是求pb~pa的问题
                        }
                }
                printf("%d\n",res);
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值