原题链接
Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8912 Accepted: 3928
Description
This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.
An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,… are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.
As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.
For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.
Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it’s the product of three H-primes.
Input
Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.
Output
For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.
Sample Input
21
85
789
0
Sample Output
21 0
85 5
789 62
Source
Waterloo Local Contest, 2006.9.30
//http://poj.org/problem?id=3292
#include <algorithm>
#include <iostream>
#include <utility>
#include <sstream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
using namespace std;
typedef long long ll;
const int MOD = int(1e9) + 7;
//int MOD = 99990001;
const int INF = 0x3f3f3f3f;
const ll INFF = (~(0ULL)>>1);
const double EPS = 1e-9;
const double OO = 1e20;
const double PI = acos(-1.0); //M_PI;
const int fx[] = {-1, 1, 0, 0};
const int fy[] = {0, 0, -1, 1};
const int maxn=1000001;
int res[maxn+5],num=0,h;
void table(){
memset(res,0,sizeof(res));
for(int i=5;i<=maxn;i+=4){//H-prime最小也是5
for(int j=5;j<=maxn;j+=4){
int t=i*j;
if(t>maxn) break;
if(res[i]==0 && res[j]==0) res[t]=1;//i与j均为H-prime,那么multiply为H-semi-primes
else res[t]=-1;//multiply为H-composite
//由于如果存在另一组i与j使得t为H-semi-primes,那么本身这个i和j就可以由别的数得到,所以这是不可能的
}
}
int cnt=0;
for(int i=1;i<=maxn;i++){
if(res[i]==1) cnt++;
res[i]=cnt;//从1到k有cnt个H-semi-primes
}
return;
}
int main(){
table();
while(scanf("%d",&h)==1 && h){
printf("%d %d\n",h,res[h]);
}
return 0;
}
/*
转载请注明出处:優YoU http://user.qzone.qq.com/289065406/blog/1309336489
大致题意:
一个H-number是所有的模四余一的数。
如果一个H-number是H-primes 当且仅当它的因数只有1和它本身(除1外)。
一个H-number是H-semi-prime当且仅当它只由两个H-primes的乘积表示。
H-number剩下其他的数均为H-composite。
给你一个数h,问1到h有多少个H-semi-prime数。
*/