POJ3046-Ant Counting-多重集组合数

原题链接
Ant Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5361 Accepted: 2024
Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1…T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.

How many groups of sizes S, S+1, …, B (1 <= S <= B <= A) can be formed?

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:

3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}

Your job is to count the number of possible sets of ants given the data above.
Input

  • Line 1: 4 space-separated integers: T, A, S, and B

  • Lines 2…A+1: Each line contains a single integer that is an ant type present in the hive
    Output

  • Line 1: The number of sets of size S…B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.
    Sample Input

3 5 2 3
1
2
2
1
3
Sample Output

10
Hint

INPUT DETAILS:

Three types of ants (1…3); 5 ants altogether. How many sets of size 2 or size 3 can be made?

OUTPUT DETAILS:

5 sets of ants with two members; 5 more sets of ants with three members
Source

USACO 2005 November Silver

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1010;
const int mod = 1000000;
int T,A,S,B,x,c[maxn];
int dp[2][100010];
int main(){
	cin >> T >> A >> S >> B;
	memset(dp,0,sizeof(dp));
	while(A--){
		scanf("%d",&x);
		c[x]++;//这里的c[i]是数量
	}
	dp[0][0]=dp[1][0]=1;
	for(int i=1;i<=T;i++){
		for(int j=1;j<=B;j++){
			if(j-1-c[i]>=0) dp[i&1][j] = (dp[i&1][j-1] - dp[(i-1)&1][j-1-c[i]] + dp[(i-1)&1][j] + mod)%mod;
			else dp[i&1][j] = (dp[i&1][j-1] + dp[(i-1)&1][j])%mod;
		}
	}
	int res = 0;
	for(int i=S;i<=B;i++) res = (dp[T&1][i] + res)%mod;
	cout << res << endl;
	return 0;
}
// #include <cstdio>
// #include <cstring>
// #include <iostream>
// using namespace std;
// const int maxn = 1010;
// int T,A,S,B,x,c[maxn];
// int dp[100010];
// int main(){
// 	cin >> T >> A >> S >> B;
// 	while(A--){
// 		scanf("%d",&x);
// 		c[x]++;
// 	}
// 	dp[0]=1;
// 	for(int i=1;i<=T;i++){
// 		for(int j=B;j>0;j--){
// 			for(int k=1;k<=c[i];k++){//明显这个效率太低,我们通过画图找关系能看出同一个i下可以进行转移
// 				if(j-k<0) break;
// 				dp[j] += dp[j-k];
// 			}
// 		}
// 		for(int j=0;j<=B;j++) cout << dp[j] << " ";
// 		cout << endl;
// 	}
// }
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值