POJ1979-Red and Black-DFS染色

原题链接
Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 33776 Accepted: 18319
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output

45
59
6
13
Source

Japan 2004 Domestic
题意:有一个矩形的房间,里面铺满了方形的瓷砖。每一个瓷砖有红色还有黑色两种,人只能站在黑色的瓷砖上不能站在红色的瓷砖上,每次只能走前后左右四个方向的四个瓷砖,计算能够到达的黑色瓷砖的总面积数。
思路:深度优先搜索,走过的地方直接变成红色

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int dx[4]={1,0,-1,0};
int dy[4]={0,-1,0,1};
int n,m;
char a[22][22];
bool used[22][22];
void dfs(int &res,int x,int y){
	used[x][y]=true;
	res++;
	for(int i=0;i<4;i++){
		int nx=x+dx[i],ny=y+dy[i];
		if(nx >= 0 && nx <n && ny >= 0 && ny < m && !used[nx][ny]){
			dfs(res,nx,ny);
			//心得:对于这种染色而不是寻找路径的这种问题,我们就不需要每次令used[x][y]=false;
		}
	}
	return;
}
int main(){
	while(scanf("%d%d",&m,&n)==2 && n+m!=0){
		int x,y;
		memset(used,false,sizeof(used));
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				cin >> a[i][j];
				if(a[i][j]=='@'){
					x=i;y=j;
				}
				else if(a[i][j]=='#'){
					used[i][j]=true;
				}
			}
		}
		int res=0;
		dfs(res,x,y);
		cout << res << endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值