POJ2718-Smallest Difference-穷竭搜索

原题链接
Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10032 Accepted: 2752
Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.
Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, …, 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.
Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.
Sample Input

1
0 1 2 4 6 7
Sample Output

28
Source
题意:这些单个的数字组成的两个数的最小差
思路:通过字典序排列排好后一分成两个数字,求此最小差
Rocky Mountain 2005

#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <iostream>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 11;
int a[maxn];
//读取一行中的数组并且存储
int read_list(){
	string line;
	getline(cin,line);
	stringstream ss(line);
	int t=0,x;
	while(ss >> x) a[t++]=x;
	return t;
}
int abs(int x){
	return x > 0 ? x : -x;
}
int main(){
	int K;
	cin >> K;
	string line;
	getline(cin,line);//使用getline总是需要先预读一个空行
	while(K--){
		int res=INF;
		int n=read_list();
		if(n==2){
			cout << abs(a[0]-a[1]) << endl;
			continue;
		}
		int mid=(n+1)/2;//如果mid=n/2那么左边一定不会是一个0,而右边也最少两个元素无法生成一个单独的0
		while(a[0]==0) next_permutation(a,a+n);//只要新生成的排列的首字符是0就继续进行排列
		do{
			if(a[mid]==0 && n-mid == 1){//要么有且仅有一个0
				int l=a[0];
				for(int i=1;i<mid;i++) l=l*10 + a[i];
				res = min(res,l);
			} 
			if(a[mid]){//要么首字符不为0
				int l=a[0],r=a[mid];
				for(int i=1;i<mid;i++) l = l*10 + a[i];
				for(int i=mid+1;i<n;i++) r = r*10 + a[i];
				res = min(res,abs(l-r));
			} 
		}while(next_permutation(a,a+n));
		cout << res << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值