POJ2236-Wireless Network-并查集

原题链接
Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 25542 Accepted: 10621
Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output

FAIL
SUCCESS
Source

POJ Monthly,HQM

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <vector>
using namespace std;
const int maxn = 1005;
typedef struct node
{
	int x,y;
}node;
node a[maxn];
vector<int> que;//存储已经修好的点
bool d[maxn][maxn];
int n,max_d,fa[maxn];
int findfa(int x){
	return fa[x]==x ? x : fa[x] = findfa(fa[x]);
}
void unite(int x,int y){//让y的祖先是x的祖先
	int fx=findfa(x);
	int fy=findfa(y);
	if(fx!=fy) fa[fy]=fx;
	return;
}
int main(){
	cin >> n >> max_d;
	int max_d2 = max_d * max_d;
	memset(d,false,sizeof(d));
	for(int i=1;i<=n;i++){
		scanf("%d%d",&a[i].x,&a[i].y);
		for(int j=1;j<=i;j++){
			if((a[i].x-a[j].x)*(a[i].x-a[j].x) + (a[i].y-a[j].y)*(a[i].y-a[j].y) <= max_d2){
				d[i][j]=true;
				d[j][i]=true;
			}
		}
	}
	for(int i=1;i<=n;i++) fa[i]=i;
	char t;
	while(cin >> t){
		if(t=='O'){
			int tn,len = que.size();
			scanf("%d",&tn);
			for(int i=0;i<len;i++){
				if(d[tn][que[i]]){
					// cout << tn << " " << que[i] << endl;
					unite(tn,que[i]);
				}
			}
			que.push_back(tn);
			// for(int i=1;i<=n;i++) printf("%d  ",findfa(i));
			// cout << endl << endl;
		}
		else{
			int tn1,tn2;
			scanf("%d%d",&tn1,&tn2);
			if(findfa(tn1)==findfa(tn2)) printf("SUCCESS\n");
			else printf("FAIL\n");
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值