POJ3666-Making the Grade-dp

原题链接
Making the Grade
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6861 Accepted: 3176
Description

A straight dirt road connects two fields on FJ’s farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, … , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . … , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|A1 - B1| + |A2 - B2| + … + |AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single integer elevation: Ai

Output

  • Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9
Sample Output

3
Source

USACO 2008 February Gold

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 2000 + 10;
const int INF = 0x3f3f3f3f;
int dp[2][maxn],a[maxn],b[maxn];// a数组是原数组,b数组是a数组排序后的数组
// 实际上a[i]变化后的结果就是成为b数组中某个位置的一个值而已,所以我们的定义dp[i][j]为在前i-1个已经
// 有序的数组中将当前位置变化为b[j]位置的数的最小花费,由于dp[i-1][k]代表的序列已经有序(0<=k<=j),
// 所以只需要考虑当前改变的消耗,dp[i][j] = min{dp[i-1][k]} + | a[i] - b[j] | 0<=k<=j
// 当然其实由于引入了前j-1最小其实我们还可以把dp写成一维的形式
int _abs(int x){
	return x > 0 ? x : -x;
}
bool cmp(int x,int y){
	return x > y ? true : false;
}
int main(){
	int n;
	while(scanf("%d",&n)==1){
		for(int i=0;i<n;i++) {scanf("%d",&a[i]);b[i]=a[i];}
		int res = INF;
		memset(dp,0,sizeof(dp));
		sort(b,b+n);//先处理升序的情况
		for(int i=0;i<n;i++){
			int pre_min = dp[(i+1)&1][0];
			dp[i&1][0] = dp[(i+1)&1][0] + _abs(a[i] - b[0]);
			for(int j=1;j<n;j++){
				pre_min = min(pre_min,dp[(i+1)&1][j]);
				dp[i&1][j] = pre_min + _abs(a[i] - b[j]);
			}
		}
		for(int i=0;i<n;i++) res = min(res,dp[(n-1)&1][i]);
		memset(dp,0,sizeof(dp));
		sort(b,b+n,cmp);//再处理降序的情况
		for(int i=0;i<n;i++){
			int pre_min = dp[(i+1)&1][0];
			dp[i&1][0] = dp[(i+1)&1][0] + _abs(a[i] - b[0]);
			for(int j=1;j<n;j++){
				pre_min = min(pre_min,dp[(i+1)&1][j]);
				dp[i&1][j] = pre_min + _abs(a[i] - b[j]);
			}
		}
		for(int i=0;i<n;i++) res = min(res,dp[(n-1)&1][i]);
		cout << res << endl;
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值