九度OJ 1076 N的阶乘 (高精度大数的乘法)

题目描述:

 输入一个正整数N,输出N的阶乘。

输入:

正整数N(0<=N<=1000)

输出:

 输入可能包括多组数据,对于每一组输入数据,输出N的阶乘

样例输入:
4
5
15
样例输出:
24
120
1307674368000
来源:
2006年清华大学计算机研究生机试真题
/*与九度OJ 1198 相比较,使用了相同的套路*/
#include <stdio.h>
using namespace std;

struct bigInteger{
    int digit[1002];
    int size;
    //初始化结构体
    void init() {
        for(int i=0;i<1002;i++) {
            digit[i] = 0;
        }
        size = 0;
    }
    //用一个小整数设置高精度整数
    void set(int x) {
        init(); //先进行初始化
        do{
            digit[size++] = x%10000;
            x /= 10000;
        }while(x!=0);
    }

    //输出高精度整数
    void output() {
        for(int i=size-1;i>=0; i--) {
            if(i!=size-1) {
                printf("%04d", digit[i]);
            }else {
                printf("%d", digit[i]);
            }
        }
        printf("\n");
    }

    //重载*运算符
    bigInteger operator * (int x) const {
        bigInteger ret;     //返回的结构体变量
        ret.init();         //初始化
        int carry = 0;         //记录进位

        //每四位进行一次处理
        for(int i=0;i<size;i++) {
            int tmp = x*digit[i] + carry;
            carry = tmp / 10000;
            tmp %= 10000;
            ret.digit[ret.size++] = tmp;
        }
        if(carry != 0) {
            ret.digit[ret.size++] = carry;
        }
        return ret;
    }
};

bigInteger a;

int main()
{
    int n;
    while(scanf("%d", &n) != EOF) {
        a.init();
        a.set(1);   //a初始化为1,即1存入高精度结构中
        for(int i=1;i<=n;i++) {     //注意不能从0开始循环
            a = a*i;
        }
        a.output();
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值