高精度减法,高精度乘法

高精度减法
oj数据偏弱如果添加一个101-2就错了,下面这一步是为了防止错误的
if(a[aa]<’0’)
{
a[aa]+=10;
a[aa-1]–;
}
可能出现第一位的1被借走的的情况,所以加一个while找第一个不是0的
while(c[i]<=’0’)
i–;

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<string.h>
#include<map>
#include<algorithm>
using namespace std;
int main()
{
   string a,b,c,temp;
   cin>>a>>b;
   if((a.length()<b.length())||(a.length()==b.length()&&a[0]<b[0]))
   {
       cout<<"-";
      temp=a;
     a=b;
    b=temp;
   }
   int i=0;
   int aa=a.length()-1;
   int bb=b.length()-1;
    while(bb>=0)
   {
        if(b[bb]<=a[aa])
      {
            c[i++]=a[aa--]-b[bb--]+'0';
    }else{
        a[aa-1]--;
      a[aa]=a[aa]+10;
     c[i++]=a[aa--]-b[bb--]+'0';
   }
   }
   while(aa>=0)
   {
      if(a[aa]<'0')
     {
        a[aa]+=10;
      a[aa-1]--;
    }
        c[i++]=a[aa--];
   }
   while(c[i]<='0')
        i--;
    for(int k=i;k>=0;k--)
   {
        cout<<c[k];
   }
   return 0;
}

高精度乘法
注意一下,字符向数组的转换。
主要思路就是两个数字相乘,第一个数字的第i位乘以第二个数字的第j位得到的将是第三个数字的第i+j位;注意一下得到数 的某一位是否大于10;

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<string.h>
#include<map>
#include<algorithm>
using namespace std;
int main()
{
    string a,b;
   cin>>a>>b;
   int al,bl;
   al=a.length();
   bl=b.length();
   int aa[1005],bb[1005];
   int c[2010]={0};
   for(int i=0;i<al;i++)
   {
        aa[al-i-1]=a[i]-'0';
   }
   for(int i=0;i<bl;i++)
   {
        bb[bl-i-1]=b[i]-'0';
   }
   for(int i=0;i<al;i++)
   {
        for(int j=0;j<bl;j++)
        {
            c[i+j]=aa[i]*bb[j]+c[i+j];
        }
   }
   for(int i=0;i<al+bl;i++)
   {
        if(c[i]>9)
      {
         c[i+1]=c[i+1]+c[i]/10;
       c[i]=c[i]%10;
     }
   }
   int cl=al+bl;
   while(cl>0&&c[cl]==0)
        cl--;
      for(int i=cl;i>=0;i--)
        cout<<c[i];
      cout<<endl;
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值