师--链表的结点插入
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
给出一个只有头指针的链表和 n 次操作,每次操作为在链表的第 m 个元素后面插入一个新元素x。若m 大于链表的元素总数则将x放在链表的最后。
Input
多组输入。每组数据首先输入一个整数n(n∈[1,100]),代表有n次操作。
接下来的n行,每行有两个整数Mi(Mi∈[0,10000]),Xi。
Output
对于每组数据。从前到后输出链表的所有元素,两个元素之间用空格隔开。
Example Input
4 1 1 1 2 0 3 100 4
Example Output
3 1 2 4
Hint
#include<stdio.h>
#include<stdlib.h>
struct node
{
int date;
struct node *next;
};
int main()
{
int n;
struct node *head, *p, *tail;
int i, sum;
while(~scanf("%d", &n))
{
int x;
head = (struct node *)malloc(sizeof(struct node));
head -> next = NULL;
sum = 1;
p = (struct node*)malloc(sizeof(struct node));
scanf("%d %d", &x, &p -> date);
p -> next = head -> next;
head -> next = p;
tail = p;
for(i = 1; i <= n - 1; i++)
{
scanf("%d", &x);
if(x >= sum)
{
p = (struct node*)malloc(sizeof(struct node));
scanf("%d", &p -> date);
p -> next = NULL;
tail -> next = p;
tail = p;
sum++;
}
/*else if(x == 0)
{
p = (struct node *)malloc(sizeof(struct node));
scanf("%d", &p -> date);
p -> next = head -> next;
head -> next = p;
sum++;
}*/
else
{
struct node *q;
q = head;
while(x--)
{
q = q -> next;
}
p = (struct node *)malloc(sizeof(struct node));
scanf("%d", &p -> date);
p -> next = q -> next;
q -> next = p;
sum++;
}
}
p = head -> next;
while(p)
{
if(p == head -> next)
{
printf("%d", p -> date);
}
else
printf(" %d", p -> date);
p = p -> next;
}
printf("\n");
}
return 0;
}
/***************************************************
User name: jk170704刘彤阳
Result: Accepted
Take time: 0ms
Take Memory: 192KB
Submit time: 2018-03-07 21:58:02
****************************************************/