数据结构实验之链表一:顺序建立链表
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。
Input
第一行输入整数的个数N;
第二行依次输入每个整数。
第二行依次输入每个整数。
Output
输出这组整数。
Example Input
8 12 56 4 6 55 15 33 62
Example Output
12 56 4 6 55 15 33 62
Hint
#include<stdio.h>
#include<stdlib.h>
struct node
{
int date;
struct node * next;
};
struct node * creat(int n)
{
struct node * head, *tail, * p;
int i;
head = (struct node *)malloc(sizeof(struct node));
head -> next = NULL;
tail = head;
for(i = 1; i <= n; i++)
{
p = (struct node*)malloc(sizeof(struct node));
scanf("%d", &p -> date);
p -> next = NULL;
tail -> next = p;
tail = p;
}
return (head);
}
int main()
{
int n;
struct node * head;
scanf("%d", &n);
struct node *p;
head = creat(n);
p = head -> next;
while(p)
{
if(p->next == NULL)
{
printf("%d\n", p->date);
}
else
{
printf("%d ", p->date);
}
p = p->next;
}
return 0;
}
/***************************************************
User name: jk170704***
Result: Accepted
Take time: 0ms
Take Memory: 148KB
Submit time: 2018-01-19 10:37:59
****************************************************/
#include<stdio.h>
#include<stdlib.h>
struct node
{
int date;
struct node * next;
};
struct node * creat(int n)
{
struct node * head, *tail, * p;
int i;
head = (struct node *)malloc(sizeof(struct node));
head -> next = NULL;
tail = head;
for(i = 1; i <= n; i++)
{
p = (struct node*)malloc(sizeof(struct node));
scanf("%d", &p -> date);
p -> next = NULL;
tail -> next = p;
tail = p;
}
return (head);
}
int main()
{
int n;
struct node * head;
scanf("%d", &n);
struct node *p;
head = creat(n);
p = head -> next;
while(p)
{
if(p->next == NULL)
{
printf("%d\n", p->date);
}
else
{
printf("%d ", p->date);
}
p = p->next;
}
return 0;
}
/***************************************************
User name: jk170704***
Result: Accepted
Take time: 0ms
Take Memory: 148KB
Submit time: 2018-01-19 10:37:59
****************************************************/