数据结构实验之链表三:链表的逆置
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。
Input
输入多个整数,以-1作为结束标志。
Output
输出逆置后的单链表数据。
Example Input
12 56 4 6 55 15 33 62 -1
Example Output
62 33 15 55 6 4 56 12
#include <stdio.h>
#include <malloc.h>
struct node
{
int data;
struct node *next;
};
int main()
{
struct node *head,*p,*tail,*q,*r;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
while(1)
{
p=(struct node*)malloc(sizeof(struct node));
scanf("%d",&p->data);
if(p->data==-1)break;
p->next=NULL;
tail->next=p;
tail=p;
}
p=head->next;
head->next=NULL;
q=p->next;
while(p)
{
p->next=head->next;
head->next=p;
p=q;
if(q)
q=q->next;
}
r=head;
while(r->next!=NULL)
{
printf("%d ",r->next->data);
r=r->next;
}
return 0;
}
/***************************************************
User name: jk170704***
Result: Accepted
Take time: 0ms
Take Memory: 156KB
Submit time: 2018-01-19 19:11:51
****************************************************/
#include <stdio.h>
#include <malloc.h>
struct node
{
int data;
struct node *next;
};
int main()
{
struct node *head,*p,*tail,*q,*r;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
while(1)
{
p=(struct node*)malloc(sizeof(struct node));
scanf("%d",&p->data);
if(p->data==-1)break;
p->next=NULL;
tail->next=p;
tail=p;
}
p=head->next;
head->next=NULL;
q=p->next;
while(p)
{
p->next=head->next;
head->next=p;
p=q;
if(q)
q=q->next;
}
r=head;
while(r->next!=NULL)
{
printf("%d ",r->next->data);
r=r->next;
}
return 0;
}
/***************************************************
User name: jk170704***
Result: Accepted
Take time: 0ms
Take Memory: 156KB
Submit time: 2018-01-19 19:11:51
****************************************************/