P4085 [USACO17DEC]Haybale Feast

题意翻译

题意:给定2个由N个数字组成的数列 F , S ,需要找到使得

k=ijFkM ∑ k = i j F k ⩾ M
的 i , j 并输出在所有满足条件的 i , j 中,
max(Si,Si+1,...Sj1,Sj) max ( S i , S i + 1 , . . . S j − 1 , S j )
的最小值。

题目描述

Farmer John is preparing a delicious meal for his cows! In his barn, he has N haybales

(1N100,000) ( 1 ≤ N ≤ 100 , 000 )
. The i th haybale has a certain flavor
Fi(1Fi109) F i ( 1 ≤ F i ≤ 10 9 )
and a certain spiciness
Si(1Si109) S i ( 1 ≤ S i ≤ 10 9 )
.

The meal will consist of a single course, being a contiguous interval containing one or more consecutive haybales (Farmer John cannot change the order of the haybales). The total flavor of the meal is the sum of the flavors in the interval. The spiciness of the meal is the maximum spiciness of all haybales in the interval.

Farmer John would like to determine the minimum spiciness his single-course meal could achieve, given that it must have a total flavor of at least

M(1M1018) M ( 1 ≤ M ≤ 10 18 )
.

输入输出格式

输入格式:

The first line contains the integers N and M , the number of haybales and the minimum total flavor the meal must have, respectively. The next N lines describe the N haybales with two integers per line, first the flavor F and then the spiciness S .

输出格式:

Please output the minimum spiciness in a single course meal that satisfies the minimum flavor requirement. There will always be at least one single-course meal that satisfies the flavor requirement.

输入输出样例

输入样例#1:

5 10
4 10
6 15
3 5
4 9
3 6

输出样例#1:

9

#include<bits/stdc++.h>
#define LL long long
#define initt(n,m) scanf("%lld%lld",&n,&m);
using namespace std;
struct ppp {
    LL int num,data;
};
bool cmp(const ppp &a,const ppp &b) {
    return a.data<b.data;
}
const int L=1e+5;
LL int n,m,f[L],s[L],sum[L];
ppp w[L];
LL int work(ppp x) {
    int mid,l,r;
    mid=l=r=x.num;
    for(int j=mid-1; j>=1; j--) {
        if(s[j]>x.data)
            break;
        l=j;
    }
    for(int j=mid+1; j<=n; j++) {
        if(s[j]>x.data)
            break;
        r=j;
    }
    if(sum[r]-sum[l-1]>=m)
        return x.data;
    return -1;
}
int main() {
    initt(n,m);
    for(int i=1; i<=n; i++) {
        scanf("%lld%lld",&f[i],&s[i]);
        sum[i]=sum[i-1]+f[i];
        w[i].data=s[i];
        w[i].num=i;
    }
    sort(w+1,w+n+1,cmp);
    for(int i=1; i<=n; i++) {
        LL  t=work(w[i]);
        if(t!=-1) {
            printf("%lld",t);
            return 0;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值