pat 1020

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
分析:给出后序和中序列,求出层序遍历,最主要的是对数组的递归调用和bfs的理解;
	后序最后一个数为root,便可以得到中序列root的位置i,左子树的位置则为0~i-1,长度为i,右子树则为i+1~n-1,长度为n-i-1(设n为最后一个数)
	相对的后序列左子树位置则为0~i-1,右子树为i~n-1;
	则分别对子树调用递归 
下面是
#include <stdio.h>
#include <string.h>
#include <vector> 
#include <stdlib.h>
#include <queue>
using namespace std;
int postorder[31];
int inorder[31];
vector<int> levelorder;

int n;
struct node {
	int data;
	node *left;
	node *right;
};
queue<node *> Q;
node * creattree(int postorder[],int inorder[],int n)
{
	if(n<=0) return NULL;
	node *root=(node *)malloc(sizeof(node));
	root->data=postorder[n-1];
	root->left=NULL; 
	root->right=NULL;
	int i;
	for(i=0;i<n;i++)
	{
		if(postorder[n-1]==inorder[i])
		break;
	}
	root->left=creattree(postorder,inorder,i);
	root->right=creattree(postorder+i,inorder+i+1,n-i-1);
	return root;
}

void pushlevel(node *root)
{
	if(root!= NULL)
	Q.push(root);
	while(!Q.empty())
	{
			node *root1=Q.front();
		if(root1->left!=NULL)
		Q.push(root1->left);
		if(root1->right!=NULL)
		Q.push(root1->right);
		levelorder.push_back(root1->data);
		Q.pop();
	}
}
int main()
{
	//int n;
	scanf("%d",&n);
	memset(postorder,0,sizeof(postorder));
	memset(inorder,0,sizeof(inorder));
	levelorder.clear();
	for(int i=0;i<n;i++)
	{
		scanf("%d",&postorder[i]);
	}
	for(int i=0;i<n;i++)
	{
		scanf("%d",&inorder[i]);
	}
	node *root1=creattree(postorder,inorder,n);
	pushlevel(root1);
	for(int i=0;i<levelorder.size();i++)
			printf(i==levelorder.size()-1?"%d\n":"%d ",levelorder[i]);
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值