2017 Multi-University Training Contest - Team 3:1008&hdu6063、RXD and math

题目:                                       

                     RXD and math

Problem Description
RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki

output the answer module 109+7 .
1n,k1018
μ(n)=1(n=1)

μ(n)=(1)k(n=p1p2pk)

μ(n)=0(otherwise)

p1,p2,p3pk are different prime numbers
 

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k .
 

Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 

Sample Input
  
  
10 10
 

Sample Output
  
  
Case #1: 999999937

思路:

通过求出几组(n,k),易得出答案为n^k%(1e9+7)

code:

#include<bits/stdc++.h>
using namespace std;
#define mod 1000000007
__int64 speedmi(__int64 a,__int64 b)
{
        __int64 ans=1;
        while(b>0){
                if(b%2==1) ans=(ans*a)%mod;
                b=b/2;
                a=(a*a)%mod;
        }
        return ans;
}
int main()
{
        __int64 n,k,sum;
        int op=1;
        while(~scanf("%I64d%I64d",&n,&k)){
                printf("Case #%d: %I64d\n",op++,speedmi(n%mod,k));
        }
        return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值