2017 Multi-University Training Contest - Team 5:1011&hdu6095、Rikka with Competition

题目:

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

A wrestling match will be held tomorrow. n players will take part in it. The i th player’s strength point is ai .

If there is a match between the i th player plays and the j th player, the result will be related to |aiaj| . If |aiaj|>K , the player with the higher strength point will win. Otherwise each player will have a chance to win.

The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After n1 matches, the last player will be the winner.

Now, Yuta shows the numbers n,K and the array a and he wants to know how many players have a chance to win the competition.

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number t(1t100) , the number of the testcases. And there are no more than 2 testcases with n>1000 .

For each testcase, the first line contains two numbers n,K(1n105,0K<109) .

The second line contains n numbers ai(1ai109) .
 

Output
For each testcase, print a single line with a single number -- the answer.
 

Sample Input
  
  
2 5 3 1 5 9 6 3 5 2 1 5 9 6 3
 

Sample Output
  
  
5 1
题意:n个人比赛,每个人有自己的分值,任意选两个人,如果|a_i-a_j|>k,那么分值大的人获胜,否则两个人都有可能获胜,求有多少人能获胜

思路:签到题。对分值排序。获胜人数处置为1,i从大到小,如果| a[i]-a[i-1] |<=k,获胜人数+1,不然就结束循环,因为继续下去没人能赢当前这个人。

CODE:

#include<bits/stdc++.h>
using namespace std;
int a[100005];
int main()
{
        int t,n,k,i;
        scanf("%d",&t);
        while(t--){
                scanf("%d%d",&n,&k);
                for(i=0;i<n;i++) scanf("%d",&a[i]);
                sort(a,a+n);
                int cnt=1;
                for(i=n-1;i>0;i--){
                        if(a[i]-a[i-1]<=k) cnt++;
                        else break;
                }
                printf("%d\n",cnt);
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值