Online Judge No.84 single number 膜巨佬

题目描述

Given an array with N integers where all elements appear three times except for one. Find out the one which appears only once.

输入格式

Several test cases are given, terminated by EOF.

Each test case consists of two lines. The first line gives the length of array N(1≤N≤105), and the other line describes the N elements. All elements are ranged in [0,263−1].

输出格式

Output the answer for each test case, one per line.

输入样例

4
1 1 1 3
10
1 2 3 1 2 3 1 2 3 4

输出样例

3
4

刚看到题目的时候想的是搞一个二维数组,弄成上面一行是数字,下面一行是个数,最后看哪个不是3,然而这样太暴力了,还浪费空间。
之后看果然巨佬的按位的运算妙极,妙就妙在计算机运算都是二进制,如果在计算机二进制运算的过程中找到规律的话就比以十进制来寻找规律要省事得多。。。
感慨良多,只得膜拜巨佬。

代码中count是一共几个,如果不是3n+1会提醒错误,input是每个输入,num1是出现了一次的位那个数,每次都和自己异或,所以一次是自己,二次就是0…奇数次都是自己,偶数次都是0;num2会发现从第二次开始就全是1;num3是第三次出现的时候,此时num1和num2都保留,同时清空之前num1和num2,最后剩下的那个就是只出现一次的,存放在num1里面。

/*
USER_ID: test#2014211369
PROBLEM: 84
SUBMISSION_TIME: 2019-01-24 17:01:07
*/
#include<stdio.h>
#include<stdlib.h>
 
int main()
{
    long long count, input, num1, num2, num3;
    int flag=0;
    while(scanf("%lld", &count)!=EOF)
    {
        num1=0, num2=0;
        if(count%3 == 1) flag=1;
        while(count--)
        {
            scanf("%lld", &input);
            num2 |= num1&input;
            num1 ^= input;
            num3 = num1&num2;
            num1 = (~num3)&num1;
            num2 = (~num3)&num2;
        }
        if(flag == 1)
        {
            printf("%lld\n", num1);
            flag=0;
        }
        else  printf("Wrong total number.\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值