5-4 List Leaves (25分)

5-4 List Leaves   (25分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 1010) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1N1. Then NN lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5


#include<stdio.h>
#include<algorithm>
#include<stdlib.h>
#include<string.h>

const int max = 11;

using namespace std;

struct TNode{
	
	int left;
	int right;
}T[11];


struct Node{
	int num;
	struct Node * next;
};
typedef struct Node * Position;
struct QNode{
	Position front,rear;
	int size;
};

typedef struct QNode * Queue;

Queue Q_create()/*创建队列*/
{
	Queue head = (Queue)malloc(sizeof(struct QNode));
	head->front = NULL;
	head->rear = NULL;
	head->size = 0;
	
	return head;
}

bool isempty(Queue q)
{
	return (q->size == 0);
}

bool isfull(Queue q)
{
	return (q->size == 11);
}

void add(Queue q,int number)
{
	Position pnew = (Position)malloc(sizeof(struct Node));
	pnew->num = number;
	pnew->next =NULL;
	
	if(isempty(q))
	{
		q->front = q->rear = pnew;
	}
	else
	{
		q->rear->next = pnew;
		q->rear = q->rear->next;
	}
	
	q->size++;/*入队的时候要记得将队列+1*/
}

int del(Queue q)
{
	Position t;
	int num;
	if(isempty(q))
	{
		return NULL;
	}
	else
	{
		t = q->front;
		if(q->front == q->rear)
		{
			q->front = q->rear = NULL;
		}
		else
		{
			q->front = q->front->next;
		}
		num = t->num;
		free(t);
		q->size--;/*出队的时候要记得将队列-1*/
	}
	
	return num;
}

int T_create()/*创建一个二叉树*/
{
	int check[11];
	int n,r,i;
	char cl,cr;
	for(int i = 0 ; i< 11; i++)
	{
		check[i] = 0;
	}
	scanf("%d",&n);
	getchar();
	if(n != 0)
	{
		for(i = 0; i < n; i++)
		{
			scanf("%c %c",&cl,&cr);
			getchar();
			if(cl != '-')
			{
				T[i].left = cl - '0';
				check[T[i].left] = 1;
			}
			else
			{
				T[i].left = -1;
			}
			
			if(cr != '-')
			{
				T[i].right = cr - '0';
				check[T[i].right] = 1;
			}
			else
			{
				T[i].right = -1;
			}
		}
		
		for(i = 0; i < n ; i++)
		{
			if(check[i] == 0)break;
		}
		r = i;
	}
	else
	{
		return -1;	
	}

	
	return r;
}

void findleaves(int t)/*采用层序遍历的方式,用队列来完成*/
{
	Queue Q = Q_create();

	add(Q,t);
	int flag = 0;
	while(!isempty(Q))
	{
		t = del(Q);
	
		if(T[t].left == -1 && T[t].right == -1)/*当当前的父结点,没有左右子结点时就输出*/
		{
			if(flag == 0)
			{
				printf("%d",t);
				flag = 1;
			}
			else
			{
				printf(" %d",t);
			}
		}

		if(T[t].left != -1)
		{
			add(Q,T[t].left);
		}
		if(T[t].right != -1)
		{
			add(Q,T[t].right);
		}
		
	}
	
}

int main(void)
{
	int r = T_create();
	findleaves(r);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值