1103. Integer Factorization (30)

1103. Integer Factorization (30)

时间限制
1200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112+ 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
 
 
 
 
思路:用fac数组记录小于等于n的数,fac[0] = 0, fac[1] = 1, fac[2] = 2^p, ...fac[x] = x^p.
在DFS中,对于每一个fac[index]的数来说都有两个路口,选和不选。选的分支被终止说明刚刚加进去的数不符,就要消去。
不选的分支触发就是试探下一个数是否可行
 
 
#include<stdio.h>
#include<stdlib.h> 
#include<math.h>
#include<string.h>
#include<algorithm>
#include <vector> 
#include<stack> 
#include <queue>  
#include<map>
#include<iostream>  
#include <functional> 
#define MAX 100001
#define MAXD 10001
#define TELNUM 10
using namespace std;

vector<int> ans,fac,temp;
int n,k,p;
int maxn = -1;

int power(int n)
{
	int j = 1;
	for(int i = 0; i < p; i++)
	{
		j *= n;
	}
	return j;
}

void init()
{
	int i = 0, t = 0;
	while(t <= n)/*把i^p放到fac数组中*/
	{
		fac.push_back(t);
		t = power(++i);
	}
}

void DFS(int index, int newK, int sum, int facsum)
{
	if(sum == n && newK == k)/*找到一个适合的区间*/ 
	{
		if(facsum > maxn)
		{
			ans = temp;/*更新底数的序列*/
			maxn = facsum;/*更新底数之和*/
		}
		return;
	}
	
	if(sum > n || newK > k)
	{
		return;
	}
	
	if(index - 1 >= 0)/*fac[0] 不考虑*/
	{
		temp.push_back(index);
		DFS(index,newK + 1,sum + fac[index],facsum + index);/*进入“选”的分支*/
		temp.pop_back();/*在选的分支被终止后,把刚刚加进去的数消去,说明刚刚加进去的数不符合要求*/
		DFS(index - 1, newK, sum, facsum);/*进入不选的分支*/ 
	}
}


int main(void)
{
	scanf("%d%d%d",&n,&k,&p);
	init();
	DFS(fac.size() - 1, 0, 0, 0);/*从fac最后一位数开始往前搜索*/
	
	if(maxn == -1)printf("Impossible\n");
	else
	{
		printf("%d = %d^%d",n,ans[0],p);
		for(int i = 1; i < ans.size(); i++)
		{
			printf(" + %d^%d",ans[i],p);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值