HDU 5533 Dancing Stars on Me

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 360    Accepted Submission(s): 217


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer  T  indicating the total number of test cases. Each test case begins with an integer  n , denoting the number of stars in the sky. Following  n  lines, each contains  2  integers  xi,yi , describe the coordinates of  n  stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
  
  
NO YES NO
 

Source

#include<stdio.h>
#include <limits.h>
int i,j,k,m,n,sum;
double a[1100],b[1100],Min; 
double ac(x,y)
{
  return ((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j])); 
}
int main()
{
scanf("%d",&k);
while(k--)
  {
    scanf("%d",&m);
    for(i=0;i<m;i++)
      {
        scanf("%lf%lf",&a[i],&b[i]);
      }
    Min=INT_MAX;//定义Min为无穷大
    for(i=0;i<m;i++)//找最小边
      for(j=i+1;j<m;j++)
        {
          Min=Min<ac(i,j)?Min:ac(i,j);
        }
    sum=0;
    for(i=0;i<m;i++)//判断最小边个数
      for(j=i+1;j<m;j++)
        if(ac(i,j)==Min)
          sum++;
    if(sum==m)//最小边个数为m时输出YES
      printf("YES\n");  
    else  
      printf("NO\n");
  }
return 0;
}

补充:
C语言 头文件 #include <limits.h> 定义了各种类型的最大值。正无穷大即比任何其他的数都大,所以在C语言中特定数据类型的正无穷大则可以用该数据类型的最大值来表示。

CHAR_BIT char的二进制位数(bit)
CHAR_MAX char的有符号整数最大值
CHAR_MIN char的有符号整数最小值
MB_LEN_MAX 多字节字符的最大字节(byte)数
INT_MAX int的有符号最大值
INT_MIN int的有符号最小值
LONG_MAX long的十进制最大值
LONG_MIN long的十进制最小值
SCHAR_MAX signedchar的十进制整数最大值
SCHAR_MIN signedchar的十进制整数最小值
SHRT_MIN short的十进制最小值
SHRT_MAX short的十进制最大值
UCHAR_MAX unsignedchar的十进制整数最大值
UINT_MAX unsignedint的十进制最大值
ULONG_MAX unsignedlongint的十进制最大值
USHRT_MAX unsignedshortint的十进制最大值



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值