PAT甲级1106 Lowest Price in Supply Chain (25分) 虽然是简单题,但是还是再捋下思路吧

1106 Lowest Price in Supply Chain (25分)
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10
​5
​​ ), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K
​i
​​ ID[1] ID[2] … ID[K
​i
​​ ]

where in the i-th line, K
​i
​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K
​j
​​ being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10
​10
​​ .

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2

还是习惯 vector< vector< int> >vec 来表示图的结点,然后一个队列进行层序遍历就搞定了,只是有点小细节需要捋一捋 。

题目在给定供应关系时候使用0来表示零售端了

  • 我是使用vec[i]=-1 来表示结点i是零售端

结果要求输出零售端最低价和最低价的供应商数目

  • 我们层数遍历时候只要遇到零售端了,那么就把该层次的所有零售端数量记录下来,该层次的价格就是我们求的最低价,实现的时候需要有个变量来判断是否遇到了零售端了,我是用的firrst=0; 如果vec[队列出队的顶点序号]=-1 那么first=1;
  • 还有一个关于顶点价格,可以在顶点入队列时候 设置入队列元素的价格,也可以在顶点出队列的时候设置顶点的价格,因为前面判断出队元素是否为零售端,还要记录出队顶点对应的价格,所以选择了第二种,在出队时候记录顶点的价格(最开始习惯性设置入队时候设置定价价格,写完了感觉不对)
#include <iostream>
#include <algorithm>
using namespace std;
#include <vector>
#include <queue>





int main()
{
    int N;
    cin>>N;
    double price[N]= {0};
    vector<vector<int>> vec(N);
    double P,r;
    cin>>P>>r;
    for(int i=0; i<N; i++)
    {
        int num;
        cin>>num;
        for(int q=0; q<num; q++)
        {
            int a;
            cin>>a;
            vec[i].push_back(a);
        }
        if(num==0)
            vec[i].push_back(-1);
    }
    queue<int> que;
    que.push(0);


    int first=0;
    int firstNum=0;
    double minn;
    while(!que.empty())
    {
        queue<int> get;
        while(!que.empty())
        {
            int getNum=que.front();
            que.pop();
            if(price[getNum]==0)
            price[getNum]=P;
            if(vec[getNum][0]!=-1)
            {
                for(int i=0; i<vec[getNum].size(); i++)
                {
                    int pushnum=vec[getNum][i];

                    get.push(vec[getNum][i]);
                }

            }
            else
            {
                first=1;
                minn=P;
                firstNum++;
            }



        }
        P=P+P*r/100;
        que=get;
        if(first==1)
            break;
    }
    printf("%.4f %d",minn,firstNum);
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值