hdu4223 Dynamic Programming?

考虑到N比较小(1<=N<=1000),可以直接暴力破解,遍历所有子序列

 

 

Dynamic Programming?

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2043    Accepted Submission(s): 951

 

 

Problem Description

Dynamic Programming, short for DP, is the favorite of iSea. It is a method for solving complex problems by breaking them down into simpler sub-problems. It is applicable to problems exhibiting the properties of overlapping sub-problems which are only slightly smaller and optimal substructure.
Ok, here is the problem. Given an array with N integers, find a continuous subsequence whose sum’s absolute value is the smallest. Very typical DP problem, right?

 

 

Input

The first line contains a single integer T, indicating the number of test cases.
Each test case includes an integer N. Then a line with N integers Ai follows.

Technical Specification
1. 1 <= T <= 100
2. 1 <= N <= 1 000
3. -100 000 <= Ai <= 100 000

 

 

Output

For each test case, output the case number first, then the smallest absolute value of sum.

 

 

Sample Input

 

2 2 1 -1 4 1 2 1 -2

 

 

Sample Output

 

Case 1: 0 Case 2: 1

/*
题意:给定一个具有N个整数的数组,找到它的一个总和绝对值最小的子序列。
但考虑到N比较小(1<=N<=1000),完全可以暴力破解。
*/

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
	int t;
	cin>>t;
	for(int k=1;k<=t;k++)
	{
		int n,min;
		int a[1010];
		cin>>n;
		for(int i=0;i<n;i++)
		   cin>>a[i];
		min=abs(a[0]);
		for(int i=0;i<n;i++)//双重循环,遍历所有子序列 
		{
			int sum=0; 
			for(int j=i;j<n;j++)
			{
				sum+=a[j];
				if(abs(sum)<min)min=abs(sum);
			}
		}
		printf("Case %d: %d\n",k,min);
	}
	return 0;
} 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值