hdu1237简单计算器-栈实现

简单计算器
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19135 Accepted Submission(s): 6730

Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output
3.00
13.36

#include <cstdio>
#include <cstring>
#include <stack>
using namespace std;
int main()
{
    int i;
    double a,b;
    char s[250],c;
    while(gets(s),strcmp(s,"0")!=0)
    {
        stack<char>s1;
        stack<double>s2;
        for(i=0; s[i]; i++)
        {
            if(s[i]>='0'&&s[i]<='9')
            {
                a=0;
                while(s[i]>='0'&&s[i]<='9')
                {
                    a=a*10+s[i]-'0';
                    i++;
                }
                i--;
                s2.push(a);
            }
            else if(s[i]=='-'||s[i]=='+')
            {
                if(!s1.empty())
                {
                    c=s1.top();
                    s1.pop();
                    a=s2.top();
                    s2.pop();
                    b=s2.top();
                    s2.pop();
                    if(c=='+')
                        a+=b;
                    else
                        a=b-a;
                    s2.push(a);
                    s1.push(s[i]);
                }
                else
                    s1.push(s[i]);
            }
            else if(s[i]=='/' || s[i] == '*')
            {
                char ch = s[i];
                b=0;
                i+=2;
                while(s[i]>='0'&&s[i]<='9')
                {
                    b=b*10+s[i]-'0';
                    i++;
                }
                i--;
                a=s2.top();
                s2.pop();
                if(ch == '/')
                a=a/b;
                else
                a = a*b;
                s2.push(a);
            }
        }
        while(!s1.empty())
        {
            c=s1.top();
            s1.pop();
            a=s2.top();
            s2.pop();
            b=s2.top();
            s2.pop();
            if(c=='+')
                a+=b;
            else
                a=b-a;
            s2.push(a);
        }
        printf("%.2f\n",s2.top());
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值