hdu1020Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45883 Accepted Submission(s): 20283

Problem Description
Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC

Sample Output
ABC
A2B3C

给一串字符,让你输出每个字符有多少个,在字符前输出数字。

指针指向每个字符,用一个while判断前后是否相等,相等则指针后移,判断一次结束就直接输出。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int main()
{
    int n;
    char str[10010];
    scanf("%d",&n);
    while(n--)
    {
        cin>>str;
        //getchar();
        int len=strlen(str);
        for(int i=0;str[i]!='\0';)
        {
            int c=1;
            while(str[i]==str[i+1])
            {
                c++;
                i++;
            }
            if(c==1)
            cout<<str[i];
            else
            cout<<c<<str[i];
            i++;
        }
        cout<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值