FatMouse' Trade

 FatMouse' Trade
Time Limit: 1000msMemory Limit: 32768KB 64-bit integer IO format:      Java class name:
Submit Status
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500






这道题是一道贪心算法,其实就是求出答案的最优解。

大致题意是:用最少的猫粮去换更多的javaBeans(也就是另一种猫粮),即用F[i]*a%Catfood换J[i]*a%JavaBeans,其实就使J[i]/F[i]的值最大,可以采用结构体排序。


#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct Node
{
    double j,f,p;
}node[1001];
int per(Node a,Node b)
{
    return a.p>b.p;//该处是求出J[i]/F[i]最大的值
}
int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n)&&(m!=-1&&n!=-1))
    {
        int i,j;
        double sum=0,midmax=0;
        for(i=0;i<n;i++)
        {
            cin>>node[i].j>>node[i].f;
            node[i].p=node[i].j/node[i].f;
        }
       sort(node,node+n,per);//进行排序
       for(i=0;i<n;i++)
       {
           if(m>node[i].f)
//以5  3为例,前两个F[i]是2+2<5,所以只需要将7+4就行,而5-2-2=1,
            {
                sum+=node[i].j;
                m-=node[i].f;
//当2+2+3>5不满足时,就求出剩下的那个猫粮的值
            }
            else
            {
                sum+=node[i].p*m;
//因为这里需要用3个猫粮才能换4个JavaBeans,所以只有一个的时候就是
//(1/3)*4,按比例求出能换的最大的javaBeans。
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值