ZOJ
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2869 Accepted Submission(s): 1894
Problem Description
读入一个字符串,字符串中包含ZOJ三个字符,个数不一定相等,按ZOJ的顺序输出,当某个字符用完时,剩下的仍然按照ZOJ的顺序输出。
Input
题目包含多组用例,每组用例占一行,包含ZOJ三个字符,当输入“E”时表示输入结束。
1<=length<=100。
Output
对于每组输入,请输出一行,表示按照要求处理后的字符串。
具体可见样例。
Sample Input
ZZOOOJJJ
ZZZZOOOOOJJJ
ZOOOJJ
E
Sample Output
ZOJZOJOJ
ZOJZOJZOJZOO
ZOJOJO
Source
浙大计算机研究生复试上机考试-2009年
#include<string.h>
#include<stdio.h>
int main()
{
char a[110],b[110];
while(scanf("%s",a)!=EOF&&(a[0]!='E'))
{
memset(b,0,sizeof(b));
int len=strlen(a);
for(int i=0;i<len;i++)
{
b[a[i]]++;
}
while(len--)
{
if(b['Z']>0)
{
printf("Z");
b['Z']--;
}
if(b['O']>0)
{
printf("O");
b['O']--;
}
if(b['J']>0)
{
printf("J");
b['J']--;
}
}
printf("\n");
}
return 0;
}
/*
#include<stdio.h>
#include<string>
int main()
{
char a[110];
while(gets(a) &&(a[0]!='E'))
{
int x=0,y=0,z=0,len=0;
len=strlen(a);
for(int i=0;i<len;i++)
{
if(a[i]=='Z') x++;
else if (a[i]=='O') y++;
else z++;
}
while(x>0||y>0||z>0)
{
if(x>0) putchar('Z'); x--;
if(y>0) putchar('O'); y--;
if(z>0) putchar('J'); z--;
}
printf("\n");
}
return 0;
}
*/