二叉树--AVL树

AVL Tree

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 642    Accepted Submission(s): 310


Problem Description
An AVL tree is a kind of balanced binary search tree. Named after their inventors, Adelson-Velskii and Landis, they were the first dynamically balanced trees to be proposed. Like red-black trees, they are not perfectly balanced, but pairs of sub-trees differ in height by at most 1, maintaining an O(logn) search time. Addition and deletion operations also take O(logn) time. 
Definition of an AVL tree 
An AVL tree is a binary search tree which has the following properties: 
1. The sub-trees of every node differ in height by at most one. 
2. Every sub-tree is an AVL tree.

Balance requirement for an AVL tree: the left and right sub-trees differ by at most 1 in height.An AVL tree of n nodes can have different height.
For example, n = 7:

So the maximal height of the AVL Tree with 7 nodes is 3.
Given n,the number of vertices, you are to calculate the maximal hight of the AVL tree with n nodes.
 

Input
Input file contains multiple test cases. Each line of the input is an integer n(0<n<=10^9).
A line with a zero ends the input.
 

Output
An integer each line representing the maximal height of the AVL tree with n nodes.
 

Sample Input
 
 
1 2 0
 

Sample Output
 
 
0 1
 

Author

scnu



题意:给结点求最大深度。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int a[46];
int n;
int main()
{
	a[0]=1;a[1]=2;
	for (int i=2;i<=45;i++)
		a[i]=a[i-1]+a[i-2]+1;
	while (~scanf("%d",&n),n)
	{
		int ans=0;
		while (a[ans]<=n) ans++;
		printf("%d\n",--ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值