poj1979——red and black

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 27797 Accepted: 15093

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

刚刚学了bfs,来试试水题!

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<queue>
using namespace std;

struct note//用结构体模拟一个队列
{
	int x;
	int y;
};

int main()
{
	int n,m;
	while(cin>>n>>m,m||n)
	{
		struct note que[401];//定义一个队列,大小为长和宽的最大值的乘积,这里是20*20;
		int tail,head;//初始化我的队列
		char a[21][21];
		int book[21][21]={0};//定义的book来标记走过的red
		int i,j,k,sum,startx,starty,tx,ty;
		int next[4][2]={{0,1},{1,0},{0,-1},{-1,0}};//这是定义方向
		
		for(i=1;i<=m;i++)//存进地图
		{
			for(j=1;j<=n;j++)
			{
				cin>>a[i][j];
				if(a[i][j]=='@')//标记初始位置
				{
					startx=i;
					starty=j;
				}
			}
		}
					
		head=1;//初始化队列
		tail=1;
		que[tail].x=startx;//把首地址入队
		que[tail].y=starty;
		tail++;
		book[startx][starty]=1;
		sum=1;//可以到达的总地点加1
		
		while(head<tail)
		{
			for(k=0;k<=3;k++)//分别朝4个方向走
			{
				tx=que[head].x+next[k][0];//用临时变量储存下一个点
				ty=que[head].y+next[k][1];//
				
				if(tx<1||tx>m||ty<1||ty>n)//判断是否越界
					continue;
					
				if(a[tx][ty]=='.'&&book[tx][ty]==0)\\这个点不是#且没有走过
				{
					sum++;//让总的可走的点数加1
					book[tx][ty]=1;//标记它为走过的点
					que[tail].x=tx;//让这点入队
					que[tail].y=ty;
					tail++;
				}
			}
			head++;//已经被延伸过的点出队
		}
		
		cout<<sum<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值