HDU-1253 胜利大逃亡 (BFS)

    好吧,上次刚傻完这次又傻了一次,先粘题目吧。

    题目:HDU-1253 胜利大逃亡

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1253

    题目:

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30989    Accepted Submission(s): 11567


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
  
  
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
  
  
11
 
    额,一道很水的BFS,感觉没什么可说的。可我为什么做了两个多小时呢,(泪目),一上来我不管三七二十一写了一个DFS交上去看见超时瞬间就知道自己又犯傻了,这是道BFS的题目啊,而且比上次做的简单很多啊,怀着沉重的心情写完了BFS,交上去傻眼了竟然WA,我勒个去回来我一步一步打印输出找问题啊找问题,找的头都疼了找了一个多小时才发现:我竟然把一个字母手滑打错了!!!写错了!!!编译不会错,样例不会错,试两次也不会错,但是会有影响!!!这种错误真的找的要吐血了,苍天啊,大地啊,为啥我就这么笨呢!!!面壁去了:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<math.h> 
using namespace std;
const int maxn=1005;
int map[52][52][52];
int timemap[52][52][52];
int k,a,b,c,t;
int dir[6][3]={{-1,0,0},{1,0,0},{0,-1,0},{0,1,0},{0,0,-1},{0,0,1}};

struct T{
	int aa,bb,cc;
};

T sa,sb;
void bfs(){
	queue<T> Q;
	sa.aa=0;
	sa.bb=0;
	sa.cc=0;
	Q.push(sa);
	timemap[0][0][0]=0;             //我用了另外一个三维数组来存储答案,其实可以直接用map来存储,实现起来省空间
	while(!Q.empty()){
		sa=Q.front();           //原理见上一篇BFS博客
		Q.pop();
		for(int i=0;i<6;i++){
		int xx=sa.aa+dir[i][0],yy=sa.bb+dir[i][1],zz=sa.cc+dir[i][2];
		if(xx>=0 && xx<a && yy>=0 && yy<b && zz>=0 && zz<c){
			if(map[xx][yy][zz]==0){
				sb.aa=xx;
				sb.bb=yy;
				sb.cc=zz;
				if(timemap[sa.aa][sa.bb][sa.cc]+1<timemap[xx][yy][zz]){
					timemap[xx][yy][zz]=timemap[sa.aa][sa.bb][sa.cc]+1;
					Q.push(sb);
				}
				
			} 
			}
		}
		
	}
}

int main(){
	scanf("%d",&k);
	while(k--){
		scanf("%d%d%d%d",&a,&b,&c,&t);
		for(int i=0;i<a;i++)
			for(int j=0;j<b;j++)
				for(int k=0;k<c;k++){
					scanf("%d",&map[i][j][k]);
					timemap[i][j][k]=maxn;
				}
		bfs();		
		if(timemap[a-1][b-1][c-1]<=t)
			printf("%d\n",timemap[a-1][b-1][c-1]);
		else
			printf("-1\n");
	}
	return 0;
}

    好吧,把超时的DFS也放上来警醒自己。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<math.h> 
using namespace std;
const int maxn=1005;
int map[52][52][52];
int k,a,b,c,t;
int dir[6][3]={{-1,0,0},{1,0,0},{0,-1,0},{0,1,0},{0,0,-1},{0,0,1}};
bool escape=0;
int ans=maxn;

void dfs(int x,int y,int z,int time){
	if(map[a-1][b-1][c-1]==2){
		if(time<ans)
			ans=time;
		return;
	}
	for(int i=0;i<6;i++){
		int tempx=x+dir[i][0],tempy=y+dir[i][1],tempz=z+dir[i][2];
		if(tempx>=0 && tempx<a && tempy>=0 && tempy<b && tempz>=0 && tempz<c){
			if(map[tempx][tempy][tempz]==0){
				map[tempx][tempy][tempz]=2;
				dfs(tempx,tempy,tempz,time+1);
				map[tempx][tempy][tempz]=0;
			}
		}
	}
}

int main(){
	scanf("%d",&k);
	while(k--){
		scanf("%d%d%d%d",&a,&b,&c,&t);
		for(int i=0;i<a;i++)
			for(int j=0;j<b;j++)
				for(int k=0;k<c;k++)
					scanf("%d",&map[i][j][k]);
		ans=maxn;
		dfs(0,0,0,0);
		if(ans<=t)
			printf("%d\n",ans);
		else
			printf("-1\n");
	}
	return 0;
}

    好好学习,天天向上~~~加油~~

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值