Poj1364 King



Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son.
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy
题意:
题目大意:已知一个序列 s[1...n],给出它的 m个子序列以及对该子序列的约束条件,例如 s[a],s[a+1],s[a+2],...,s[a+b];且s[a]+s[a+1]+s[a+2]+...+s[a+b] < or > k。问题关键在于如何转化约束条件,用前n项和来转化成两两之间的关系。如:s[a]+s[a+1]+...+s[a+b] < k 可以转化成前n项和 sum[a+b]-sum[a-1] < k,为了能用Bellman_Ford,即将'<'转化成'<=',可以写成sum[a+b]-sum[a-1] <= k-1.若是 s[a]+s[a+1]+...+s[a+b] > k 可转化成 sum[a+b]-sum[a-1] >= k+1, 即 sum[a-1]-sum[a+b] <= -k-1;
题解:
Source Code
#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <algorithm>
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
#define mem(a) memset(a, 0, sizeof(a))
#define eps 1e-5
#define M 100005
#define INF 100003
using namespace std;//sexy love//
int aa,bb;
int n,nedge;
int dis[105];
struct
{
    int s,e,v;
}edge[105];
void add(int q,int w,int e)
{
    edge[nedge].s=q;
    edge[nedge].e=w;
    edge[nedge].v=e;
    nedge++;
}
int relax(int q,int w,int e)
{
    if(dis[q]+e<dis[w])
    {
        dis[w]=dis[q]+e;
        return 1;
    }
    return 0;
}
int BellmanFord(int s0)
{
    int i, j;
    for (i=0; i<=aa; i++)
        dis[i] = INF;
    dis[s0] = 0;
    for (i=1; i<=aa; i++)
        for (j=0; j<nedge; j++)
            relax(edge[j].s, edge[j].e, edge[j].v);
    for (i=0; i<nedge; i++)
        if (relax(edge[i].s, edge[i].e, edge[i].v))
            return 1;
    return 0;
}
int main()
{
    while(cin>>aa)
    {
        nedge=0;
        if(aa==0)
            break;
        cin>>bb;
        int a,b,k;
        char c[6];
        for(int i=0;i<bb;i++)
        {
            cin>>a>>b>>c>>k;
            if (c[0] == 'l')
                add(a-1, a+b, k-1);
            else
                add(a+b, a-1, -k-1);
        }
        if (!BellmanFord(0))
           cout<<"lamentable kingdom"<<endl;
        else
            cout<<"successful conspiracy"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值