Hdu1533带权二分图的最小匹配



Going Home

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3961    Accepted Submission(s): 2036


Problem Description
On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.
 


Input
There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.
 


Output
For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.
 


Sample Input
  
  
2 2 .m H. 5 5 HH..m ..... ..... ..... mm..H 7 8 ...H.... ...H.... ...H.... mmmHmmmm ...H.... ...H.... ...H.... 0 0
 


Sample Output
  
  
2 10 28

#include<iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
const int MAXN=110;
const int inf=1<<30;
using namespace std;
char G[MAXN][MAXN];
int map[MAXN][MAXN];
int lx[MAXN],ly[MAXN];
int match[MAXN];
bool visitx[MAXN],visity[MAXN];
int n;

int Hungary(int u){
    visitx[u]=true;
    for(int i=0;i<n;i++){
        if(!visity[i]&&lx[u]+ly[i]==map[u][i]){
            visity[i]=true;
            if(match[i]==-1||Hungary(match[i])){
                match[i]=u;
                return true;
            }
        }
    }
    return false;
}

void KM_prefect_match(){
    int tmp;
    //注意,此时要初始化为无穷小
    for(int i=0;i<n;i++){
        lx[i]=-inf;
    }
    memset(ly,0,sizeof(ly));
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            lx[i]=max(lx[i],map[i][j]);
        }
    }
    for(int i=0;i<n;i++)
    {
        while(1){
            memset(visitx,false,sizeof(visitx));
            memset(visity,false,sizeof(visity));
            if(Hungary(i))//匹配成功
                break;
            else {
                tmp=inf;
                for(int j=0;j<n;j++)if(visitx[j]){//x在交错树中
                    for(int k=0;k<n;k++){
                        //y在交错树外
                        if(!visity[k]&&tmp>lx[j]+ly[k]-map[j][k]){
                            tmp=lx[j]+ly[k]-map[j][k];
                        }
                    }
                }
                //更新顶标
                for(int j=0;j<n;j++){
                    if(visitx[j])
                        lx[j]-=tmp;
                    if(visity[j])
                        ly[j]+=tmp;
                }
            }
        }
    }
}

int main(){
    int row,col;
    while(~scanf("%d%d",&row,&col)){
        if(row==0&&col==0)break;
        n=0;
        int cnt1=0,cnt2=0;
        memset(map,0,sizeof(map));
        memset(match,-1,sizeof(match));
        for(int i=0;i<row;i++){
            scanf("%s",G[i]);
            for(int j=0;j<col;j++){
                if(G[i][j]=='m')n++;
            }
        }
        //建图很重要!!!
        for(int i=0;i<row;i++){
            for(int j=0;j<col;j++){
                if(G[i][j]=='m'){
                    for(int k=0;k<row;k++){
                        for(int l=0;l<col;l++){
                            if(G[k][l]=='H'){
                                map[cnt1][cnt2++]=-1*(abs(i-k)+abs(j-l));//由于求得是最小权值和,取相反数
                            }
                        }
                    }
                    cnt1++;
                    cnt2=0;
                }
            }
        }
        KM_prefect_match();
        int ans=0;
        for(int i=0;i<n;i++){
            ans+=map[match[i]][i];
        }
        printf("%d\n",-ans);//最后取相反数就行了
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值