POJ 3071 概率DP

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. Aftern rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such thatpij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containingn (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, thejth value on the ith line represents pij. The matrixP will satisfy the constraints that pij = 1.0 − pji for all i j, and pii = 0.0 for alli. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either thedouble data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) +P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

题意:

有2^n支队伍,淘汰赛制,给出第i个队打赢第j个队的概率(pij),求哪个队赢得概率比较大?

题解:
dp[i][j]表示当前是第i轮比赛,j胜出出的概率值,设第i轮和j比赛的是k队,枚举k,则j队胜利的概率为前一轮j胜利的概率乘上前一轮k胜利的慨率乘p(j,k)

则状态转移方程为:

 dp[i][j]+=dp[i-1][k]*dp[i-1][j]*p[j][k];
再考虑枚举k的事情,因为只能跟相邻的打,所以k有限制条件,
先给出一个例子,假设有4个队。编号为0,1,2,3.(0,1),(2,3)之间产生两个胜者,假设1,3,第二轮比赛,重新编号,
则1号队的新编号为0,3号队的新编号为1,规律为i,j的第i-1位上的数字不等就可能交手。
代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define eps 1e-10
#define N (1<<7)+5
#define inf 1<<20
#define zero(a) (fabs(a)<eps)
#define lson (step<<1)
#define rson (step<<1|1)
using namespace std;
double p[N][N];
double dp[10][N];
int main(){
    int n;
    while(scanf("%d",&n)!=EOF&&n!=-1){
        for(int i=0;i<(1<<n);i++)
            for(int j=0;j<(1<<n);j++)
                scanf("%lf",&p[i][j]);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<(1<<n);i++) dp[0][i]=1;
        for(int i=1;i<=n;i++){
            for(int j=0;j<(1<<n);j++){
                for(int k=0;k<(1<<n);k++){
                    if(((j>>(i-1))^1)==(k>>(i-1)))
                        dp[i][j]+=dp[i-1][k]*dp[i-1][j]*p[j][k];
                }
            }
        }
        double ans=0;
        int idx=-1;
        for(int i=0;i<(1<<n);i++)
            if(dp[n][i]>ans){
                ans=dp[n][i];
                idx=i+1;
            }
        printf("%d\n",idx);
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值