HDU 1394 Minimum Inversion Number



Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17930    Accepted Submission(s): 10891


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
题意:给你n个数,每次把第一个数放到最后,问最小的逆序数是多少。
题解:
首先,用线段树求解逆序数,判断是否是逆序数,我们只需判断两个数在区间的位置关系和大小关系即可,既如果x>y,但是在序列中x排在Y的前面,这就是逆序。联系到线段树上,先建一棵空树,我们每次将序列中最小数a所在位置更新到线段树里,求它后面区间的和,因为它后面区间如果有数b的话,说明b是比a小的 ,而b在区间的位置却比a在区间的位置靠后。然后把当前位置加+1.这样我们求出了最开始的数列的逆序数。然后将第一个数a放到序列的最后面,此时,逆序数的改动只和数a有关系, 既之前小于a的数(设为x,则x=a)从逆序数变成不是逆序数,之前大于a的数(设为y,则y=(n-(a+1))从不是逆序数变成逆序数,则
a放到最后逆序数的改变就是ans+y-x。求最小值即可。
代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
#define M  5040
using namespace std;
int n,x,sum[M],b[M];
struct node
{
    int x,id;
    bool operator <(const node&n)const
    {
        return x<n.x;
    }
} dian[M];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]=0;
        return ;
    }
    int mid=(r+l)>>1;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
    pushup(rt);
}
int  query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        return sum[rt];
    }
    int mid=(l+r)>>1;
    int ans=0;
    if(L<=mid)
        ans+=query(L,R,l,mid,rt<<1);
    if(R>mid)
        ans+=query(L,R,mid+1,r,rt<<1|1);
    return ans;
}
void update(int q,int add,int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]+=add;
        return ;
    }
    int mid=(r+l)>>1;
    if(q<=mid)
        update(q,add,l,mid,rt<<1);
    else
        update(q,add,mid+1,r,rt<<1|1);
    pushup(rt);
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(b,0,sizeof(b));
        memset(sum,0,sizeof(sum));
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&x);
            b[i]=x;
            dian[i].x=x;
            dian[i].id=i;

        }
        sort(dian+1,dian+n+1);
        build(1,n,1);
        int he=0;
        for(int i=1; i<=n; i++)
        {
            he+=query(dian[i].id,n,1,n,1);
            update(dian[i].id,1,1,n,1);
        }
        int mi=he;
        for(int i=1; i<n; i++)
        {
            he+=n-2*b[i]-1;
            mi=min(mi,he);
        }
        printf("%d\n",mi);

    }


}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值