HDU5512(Pagodas)

Pagodas
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 983    Accepted Submission(s): 694


Problem Description

n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1≤a≠b≤n) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j−k. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

 


Input

The first line contains an integer t (1≤t≤500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2≤n≤20000) and two different integers a and b.

 


Output

For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.

 


Sample Input

16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12


 


Sample Output

Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka

题意:给出你n个山头和初始已经被占领的两个山头,每次你可以在已经被占领的山头中任选两个,然后占领他们的编号和或差的山头(之前未被占领),Yuwgna先手,Iaka后手,直到没有山头占领或者所有的山头都被占领,输出最后的胜者。

题解:

很好的一道”博弈题“,我们可以明确的是,只要能占领山头1,所有的山头都能被占领。 既最先的两个山头有1或者他俩的GCD==1, 否则我们只能占领n/gcd(x,y)个山头。判断奇偶性即可,

代码:

#include<stdio.h>
#include<iostream>
#include<stdlib.h>
using namespace std;
int gcd(int x,int y)
{
    return y==0?x:gcd(y,x%y);
}
int main()
{
    int t,a,b,c;
    scanf("%d",&t);
    int ge=1;
    while(t--)
    {
        scanf("%d%d%d",&a,&b,&c);
        if(b<c)
            swap(b,c);
        printf("Case #%d:",ge++);
        int d=gcd(b,c);
        if(c==1||d==1)
        {
            if(a%2==1)
            {
                cout<<" Yuwgna"<<endl;
            }
            else
            {
                cout<<" Iaka"<<endl;
            }
        }
        else
        {
            a/=d;
            if(a%2==1) cout<<" Yuwgna"<<endl;
            else cout<<" Iaka"<<endl;

        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值