HDU 4734 F(x) (数位dp)



F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4642    Accepted Submission(s): 1725


Problem Description
For a decimal number x with n digits (AnAn-1An-2 ... A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

Source
 题意:给你a,b,,f(a) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1. (An为对应的十进制上的数),问0-b之间有多少个数满足f(b)<=f(a).
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include <stack>
#include <map>
#define ll long long
using namespace std;
int dp[10][200000],a[20];
int dfs(int pos,int zhi,bool limit)
{
    if(pos==-1)
        return zhi>=0;
    if(zhi<0)
        return 0;
    if(!limit&&dp[pos][zhi]!=-1)
        return dp[pos][zhi];
    int up=limit?a[pos]:9;
    int ans=0;
    for(int i=0;i<=up;i++)
    {
        ans+=dfs(pos-1,zhi-i*(1<<pos),limit&&i==a[pos]);
    }
    if(!limit)
        dp[pos][zhi]=ans;
    return ans;
}
int f(int x)
{
    int ans=0;
    int tmp=1;
    while(x)
    {
        ans+=x%10*tmp;
        x/=10;
        tmp*=2;
    }
    return ans;
}
int solo(int x,int y)
{
    int pos=0;
    while(y)
    {
        a[pos++]=y%10;
        y/=10;
    }
    return dfs(pos-1,f(x),true);
}
int main()
{
    int t,l,r;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));
    for(int i=1;i<=t;i++)
    {
        cin>>l>>r;
        printf("Case #%d: %d\n",i,solo(l,r));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值