HDU 5935 Car(思维,模拟,精度)



Car

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 523    Accepted Submission(s): 185


Problem Description
Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught the attention of the traffic police. Police record
N positions of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at 0 .

Now they want to know the minimum time that Ruins used to pass the last position.
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case begins with an integers
N , which is the number of the recorded positions.

The second line contains
N numbers a1 , a2 , , aN , indicating the recorded positions.

Limits
1T100
1N105
0<ai109
ai<ai+1
 

Output
For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum time.
 

Sample Input
  
  
1 3 6 11 21
 

Sample Output
  
  
Case #1: 4
题意:,给出n个点坐标,一辆车以不递减的速度行驶,路过每一个点的时间都是整数,问最短的时间。
题解:
刚上手感觉没法做的样子,后来倒着想。因为每过一个点的时间都是整数,求最短时间,所以最后一段所用的时间一定是1s
这样我们可以求得最后一段的速度。则前一段的速度<=这段的速度,时间=前一段的距离/这段的速度,向上取整,注意精度问题,用分数表示速度。
代码:
#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int N=1e5+10;
ll a[N];
int T,n;
int main()
{
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        printf("Case #%d: ",i);
        scanf("%d",&n);
        for(int j=1;j<=n;j++)
        {
            scanf("%I64d",&a[j]);
        }
        ll output=0;
        ll fenmu,fenzi;
        for(int j=n;j>=1;j--)
        {
            if(j==n)
            {
                output++;
                fenzi=a[j]-a[j-1];
                fenmu=1;
            }
            else
            {
                ll dis=a[j]-a[j-1];
                fenmu*=dis;
                swap(fenzi,fenmu);
                ll tmp=fenzi/fenmu+1;
                if(fenzi%fenmu==0)
                    tmp--;
                output+=tmp;
                fenzi=dis;
                fenmu=tmp;
            }
        }
       printf("%I64d\n",output);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值