HDU5952Counting Cliques(dfs)

Counting Cliques
Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1170 Accepted Submission(s): 449

Problem Description

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph.

Input

The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

Output

For each test case, output the number of cliques with size S in the graph.

Sample Input

3
4 3 2
1 2
2 3
3 4
5 9 3
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
6 15 4
1 2
1 3
1 4
1 5
1 6
2 3
2 4
2 5
2 6
3 4
3 5
3 6
4 5
4 6
5 6

Sample Output

3
7
15
题意:给你n个点m条边的无向图,问顶点数为s的团的个数。
题解:dfs 枚举每一个点,看他能形成多少个满足条件的团,然后剩下的团不会含有上一个点,保证团不会重复计算。
代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include <map>
#include <vector>
using namespace std;
const int N=1200;
vector<int>ed[N];
int mp[N][N];
int n,m,s,t,ans,x,y;
void dfs(int u,int *cnt,int size)
{
    if(size==s)
    {
        ans++;
        return ;
    }
    bool p;
    for(int i=0; i<ed[u].size(); i++)
    {
        int v=ed[u][i];
        p=true;
        for(int j=1; j<=size; j++)
        {
            if(!mp[cnt[j]][v])
            {
                p=false;
                break;
            }
        }
        if(p)
        {
            size++;
            cnt[size]=v;
            dfs(v,cnt,size);
            cnt[size]=0;
            size--;
        }
    }
}
void init()
{
    for(int i=1; i<=n; i++)
    {
        ed[i].clear();
    }
    memset(mp,0,sizeof(mp));
    ans=0;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&s);
        init();
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&x,&y);
            if(x>y)
                swap(x,y);
            ed[x].push_back(y);
            mp[x][y]=mp[y][x]=1;
        }
        for(int i=1; i<=n; i++)
        {
            int size=1;
            int cnt[N];
            cnt[1]=i;
            dfs(i,cnt,size);
        }
        printf("%d\n",ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值