Hrbust 2311(Swiss-system tournament)归并排序

Swiss-system tournament
Time Limit: 2000 MS Memory Limit: 131072 K
Total Submit: 36(6 users) Total Accepted: 7(4 users) Rating: Special Judge: No
Description
A Swiss-system tournament is a tournament which uses a non-elimination format. The first tournament of this type was a chess tournament in Zurich in 1895, hence the name “Swiss system”. The tournament will be held based on following rules.

2*N contestants (indexed 1, 2, …, 2*N) will have R rounds matches. Before the first round, every contestant has an origin score. After every match, winner will get 1 score and loser will get 0 score. Before and after every round, contestants will be sorted by their scores in descending order. Two contestants with the same score will be sorted by their index with ascending order.

In every round, contestants will have match based on the sorted list. The first place versus the second place, the third place versus the forth place, …, the Kth place versus the (K + 1)th place, …, the (2*N - 1)th place versus (2*N)th place.

Now given the origin score and the ability of every contestant, we want to know the index of the Qth place contestant. We ensured that there won’t be two contestants with the same ability and the contestant with higher ability will always win the match.

Input
Multiple test cases. The first line contains a positive integer T (T<=10) indicates the number of test cases.

For each test case, the first line contains three positive integers N (N <= 100,000), R (R <= 50), Q (Q <= 2*N), separated by space.

The second line contains 2*N non-negative integers, s1, s2, …, s2*N, si (si<= 10^8) indicates the origin score of constant indexed i.

The third line contains 2*N positive integers, a1, a2, …, a2*N, ai (ai<= 10^8) indicates the ability of constant indexed i.

Output
One line per case, an integer indicates the index of the Qth place contestant after R round matches.
Sample Input
1

2 4 2

7 6 6 7

10 5 20 15

Sample Output
1
Hint

Versus

Scores after round

Index

/

①(10)

②(5)

③(20)

④(15)

Origin

/

7

6

6

7

Round 1

① VS ④ ② VS ③

7

6

7

8

Round 2

④ VS ① ③ VS ②

7

6

8

9

Round 3

④ VS ③ ① VS ②

8

6

9

9

Round 4

③ VS ④ ① VS ②

9

6

10

9

题意:给出每个人的编号,分数,和能力值大小,m次比赛,每次按分数优先,编号其次排序。每次比赛相邻两个人比,能力值大的分数加1,再排序。问第m次后 排名为k的人的编号。
题解:模拟肯定是o(nmlogn)。会T。于是想到减少一个log。我们发现,每次比赛,会把人分成两个单调队列(加分的和没加的)。然后就可以归并了。。。
代码:

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<vector>
#include<cmath>
#include<set>
#include<string.h>
#define ll long long
using namespace std;
const int N=1e5+10;
struct node
{
    int id,pi,sore;
    bool operator <(const node &t)const
    {
        return sore>t.sore||(sore==t.sore&&id<t.id);
    }
}a[N<<1],b[N],c[N];
int t,n,m,k;
void solo()
{
    int num1=0,num2=0;
    for(int o=0;o<n;o+=2)
    {
        if(a[o].pi>a[o+1].pi)
        {
            b[num1]=a[o];
            b[num1].sore++;
            num1++;
            c[num2++]=a[o+1];
        }
        else
        {
            b[num1]=a[o+1];
            b[num1].sore++;
            num1++;
            c[num2++]=a[o];
        }
    }
    int i=0,j=0;
    int num=0;
    while(i<num1&&j<num2)
    {
        if(b[i].sore>c[j].sore||(b[i].sore==c[j].sore&&b[i].id<c[j].id)) a[num++]=b[i++];
        else a[num++]=c[j++];
    }
    while(i<num1) a[num++]=b[i++];
    while(j<num2) a[num++]=c[j++];
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        n*=2;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i].sore);
            a[i].id=i+1;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i].pi);
        }
        sort(a,a+n);
        while(m--)
        {
            solo();
        }
        printf("%d\n",a[k-1].id);
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值