sdut 3252 Lowest Unique Price

Lowest Unique Price

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic Discuss

Problem Description

Recently my buddies and I came across an idea! We want to build a website to sell things in a new way.

For each product, everyone could bid at a price, or cancel his previous bid, finally we sale the product to the one who offered the “lowest unique price”. The lowest unique price is defined to be the lowest price that was called only once.

So we need a program to find the “lowest unique price”, We’d like to write a program to process the customers’ bids and answer the query of what’s the current lowest unique price.

All what we need now is merely a programmer. We will give you an “Accepted” as long as you help us to write the program.

Input

The first line of input contains an integer T, indicating the number of test cases (T ≤ 60).

Each test case begins with a integer N (1 ≤ N ≤ 200000) indicating the number of operations.

Next N lines each represents an operation.

There are three kinds of operations:

“b x”: x (1 ≤ x ≤ 10^6) is an integer, this means a customer bids at price x.

“c x”: a customer has canceled his bid at price x.

“q” : means “Query”. You should print the current lowest unique price.

Our customers are honest, they won\’t cancel the price they didn’t bid at.

Output

Please print the current lowest unique price for every query (“q”). Print “none” (without quotes) if there is no lowest unique price.

Example Input

2
3
b 2
b 2
q
12
b 2
b 2
b 3
b 3
q
b 4
q
c 4
c 3
q
c 2
q

Example Output

none
none
4
3
2
题意:n次操作,b x,插入值为x的数。c x,删除值为x的数。q 输出出现次数为1且最小的数。
题解:set+map。
代码:

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<vector>
#include<cmath>
#include<set>
#include<map>
#include<string.h>
#define ll long long
using namespace std;
int t,n,x;
map<int,int>mp;
set<int>s;
char ss[100];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        mp.clear();
        s.clear();
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",ss);
            if(ss[0]=='b')
            {
                scanf("%d",&x);
                mp[x]++;
                if(mp[x]==1) s.insert(x);
                else s.erase(x);
            }
            else if(ss[0]=='c')
            {
                scanf("%d",&x);
                mp[x]--;
                if(mp[x]==1) s.insert(x);
                else s.erase(x);
            }
            else
            {
                if(s.empty()) cout<<"none"<<endl;
                else
                cout<<*s.begin()<<endl;
            }
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值