1021. Deepest Root (25) 并查集+BFS

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components

这题死在读题目上了,没读懂。刚看以为是输出某层结点数最多的。。发现不是,百度翻译出来的


题意:给你n个结点,然后n-1行,给出结点之间的联系,然后求的是从一个节点出发可以到达的最大深度,求出来最大深度的结点


思路:先用并查集判断是否为连通的,DFS感觉会超时10000的数据,我用的BFS,从每个结点分别遍历一遍,把最大的深度保存起来

最后比较输出。

#include<iostream>  
#include<cstring>  
#include<cstdio>  
#include<queue>  
#include<stack>  
#include<algorithm>  
#include<vector> 
#include<set>
using namespace std;  
int father[10000+10];
vector<int> v[10000+10];
int len[10000+10]={0},m[10000+10]={0};
	int n;
void Init(int x){
	for(int i=1;i<=x;i++) father[i]=i;
}
int find(int x){
	if(x==father[x]) return x;
	return father[x]=find(father[x]);
}
void Ini(){
	for(int i=0;i<=n;i++) m[i]=0;
}
void bfs(int num){
	queue<int> que;
	que.push(num);
	Ini();
	m[num]=1;
	int fz[10000+10]={0};
	int max=0;
	while(que.size()){
		int x=que.front();
		que.pop();
		for(int i=0;i<v[x].size();i++){
			if(m[v[x][i]]==1) continue;
			m[v[x][i]]=1;
			que.push(v[x][i]);
			fz[v[x][i]]=fz[x]+1;
			if(fz[v[x][i]]>max) max=fz[v[x][i]];
		}		
	}
	if(max>len[num]) len[num]=max;
}
int main(){

	cin>>n;
	Init(n);
	for(int i=1;i<n;i++){
		int a,b;
		cin>>a>>b;
		v[a].push_back(b);
		v[b].push_back(a);
		a=find(a);
		b=find(b);
		if(a!=b){
			father[a]=b;
		}
	}
	set<int> s;
	for(int i=1;i<=n;i++){
		s.insert(find(i));
	}
	if(s.size()>1){
		printf("Error: %d components",s.size());
	}
	else{
		for(int i=1;i<=n;i++){
			bfs(i);
		}
    	int max=0;
    	for(int i=1;i<=n;i++){
	    	if(len[i]>max) max=len[i];
    	}
    	for(int i=1;i<=n;i++){
		    if(len[i]==max) cout<<i<<endl;
	    }
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值