Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:2 5 1234567890001 95 1234567890005 100 1234567890003 95 1234567890002 77 1234567890004 85 4 1234567890013 65 1234567890011 25 1234567890014 100 1234567890012 85Sample Output:
9 1234567890005 1 1 1 1234567890014 1 2 1 1234567890001 3 1 2 1234567890003 3 1 2 1234567890004 5 1 4 1234567890012 5 2 2 1234567890002 7 1 5 1234567890013 8 2 3 1234567890011 9 2 4
每个考场的人是一起输入的,可以在输入结束后就对当个考场的人进行,排序合并,然后求出来考场排名
如果全部求出来在排序合并有可能会出现超时
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<stack>
#include<algorithm>
#include<vector>
#include<set>
using namespace std;
typedef struct student{
char name[20];
int score;
int kind;
int final_rank;
int local_rank;
}student;
bool cmp(student s1,student s2){
if(s1.score==s2.score){
return strcmp(s2.name,s1.name)>0;
}
return s1.score>s2.score;
}
int main(){
int n;
cin>>n;
getchar();
student stu[40000];
int sum=0;
for(int i=1;i<=n;i++){
int k;
cin>>k;
getchar();
student st[500];
for(int j=0;j<k;j++){
cin>>st[j].name>>st[j].score;
}
sort(st,st+k,cmp);
int f=1,sco=st[0].score;
for(int j=0;j<k;j++){
if(st[j].score==sco){
strcpy(stu[sum].name,st[j].name);
stu[sum].kind=i;
stu[sum].score=st[j].score;
stu[sum].local_rank=f;
sum++;
}
else{
strcpy(stu[sum].name,st[j].name);
stu[sum].score=st[j].score;
stu[sum].kind=i;
stu[sum].local_rank=j+1;
f=j+1;
sco=stu[sum].score;
sum++;
}
}
}
sort(stu,stu+sum,cmp);
int fz=1,sco=stu[0].score;
stu[0].final_rank=fz;
for(int i=1;i<sum;i++){
if(stu[i].score==sco){
stu[i].final_rank=fz;
}
else{
stu[i].final_rank=i+1;
fz=i+1;
sco=stu[i].score;
}
}
cout<<sum<<endl;
for(int i=0;i<sum;i++){
cout<<stu[i].name<<" "<<stu[i].final_rank<<" "<<stu[i].kind<<" "<<stu[i].local_rank<<endl;
}
return 0;
}