1030. Travel Plan (30)

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

做完这道题发现之前写过好多Dijkstra的题目都有瑕疵,但是评测系统没有评测出来。。


思路:直接Dijkstra求出来最短路径,关于cost

如果len[i]>map[i][num]+len[num]  那么cost直接更新

如果len[i]=map[i][num]+len[num]  cost需要判断一下

if(cost[i]>map2[i][num]+cost[num]) 
 cost[i]=map2[i][num]+cost[num]; 然后进行更新

还有就是纪录路径的问题,路径记录前驱。要注意的是如果if(cost[i]<=map2[i][num]+cost[num]) 是不更新前驱的

因为要找到最短路径下的最短消费嘛,只有这种情况不更新,其他都更新前驱



#include<iostream>  
#include<cstring>  
#include<cstdio>  
#include<queue>  
#include<stack>  
#include<algorithm>  
#include<vector> 
#include<set>
using namespace std;
typedef struct node{
	int x,len;
	friend bool operator<(node n1,node n2){
		return n1.len>n2.len;
	}
}node;
typedef pair<int,int> P;
int map[501][501],v[501]={0},len[501],cost[501],path[501]={0};
int map2[501][501];
const int INF=1<<29;
int s,d;
int n,m;
void Dijkstra(int s){
	for(int i=0;i<n;i++) len[i]=INF,cost[i]=INF;
	len[s]=0,cost[s]=0;
	priority_queue<P,vector<P>,greater<P> > que;
	que.push({len[s],s}); 
	while(que.size()){
		P p=que.top();
		que.pop();
		int num=p.second;
		if(v[num]) continue;
		v[num]=1;
		for(int i=0;i<n;i++){
			if(map[i][num]!=INF&&len[i]>=map[i][num]+len[num]){
				if(len[i]>map[i][num]+len[num]){
					cost[i]=map2[i][num]+cost[num];
					path[i]=num;
				}
				else{
					if(cost[i]>map2[i][num]+cost[num]) 
					 cost[i]=map2[i][num]+cost[num],path[i]=num;
				}
				len[i]=map[i][num]+len[num];
				
				
				
				que.push({len[i],i});
			}
		}
	}
}
int main(){

	cin>>n>>m>>s>>d;
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++) map[i][j]=INF,map2[i][j]=INF;
	}
	
	for(int i=0;i<m;i++){
		int a,b,c,d;
		cin>>a>>b>>c>>d;
		map[a][b]=c;
		map[b][a]=c;
		map2[a][b]=d;
		map2[b][a]=d;
	}
	Dijkstra(s);
	stack<int> sta;
	int fz=d;
	while(path[fz]!=s){
	    sta.push(path[fz]);
	    fz=path[fz];
	}
	cout<<s;
	while(sta.size()) {
		cout<<" "<<sta.top();
		sta.pop();
	}
	cout<<" "<<d<<" "<<len[d]<<" "<<cost[d];
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值