1135. Is It A Red-Black Tree (30) 红黑树

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

Figure 1
Figure 2
Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (<=30) which is the total number of cases. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:
3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17
Sample Output:
Yes
No
No
先根据先序建立好搜索树。

*1115. Counting Nodes in a BST (30) <二叉搜索树>

主要是判断条件4和5

判断4: 

         首先根据层序遍历判断,如果出现num<0,然后看linktree的左节点和右节点的num是否小于0,小于0 就是No 不满足条件4

判断5:

从节点到每一个叶子节点的黑节点数目相同,直接可以判断从叶子节点到其他父节点的黑色节点数是否相同。


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef struct tree{
	int num;
	struct tree *left,*right;
}tree,*linktree;
linktree creat(linktree head,int num){
	if(head==NULL){
		head=new tree();
		head->num=num;
		head->left=NULL;
		head->right=NULL;
	}
	else if(abs(num)<=abs(head->num)){
		head->left=creat(head->left,num);
	}
	else if(abs(num)>=abs(head->num)){
		head->right=creat(head->right,num);
	}
	return head;
}
int pd(linktree head){
	queue<linktree> que;
	que.push(head);
	while(que.size()){
		linktree t=que.front();
		que.pop();
		int num=t->num;
		if(num<0){
			if(t->left){
				if(t->left->num<0) return 0;
			}
			if(t->right){
				if(t->right->num<0) return 0;
			} 
		}
		if(t->left) que.push(t->left);
		if(t->right) que.push(t->right);
	}
	return 1;
}
int flag=1;
int dfs(linktree head){
	if(head==NULL) return 0;
	int zuo=dfs(head->left);
	int you=dfs(head->right);
	if(zuo!=you) flag=0;
	if(head->num>0){
		return max(zuo,you)+1;
	}
	else return max(zuo,you);
}
int main(){
	int k;
	cin>>k;
	while(k--){
		int len;
		scanf("%d",&len);
		linktree head=NULL;
		flag=1;
		for(int i=0;i<len;i++){
			int num;
			scanf("%d",&num);
			head=creat(head,num);
		}
		if(head->num<0){
			printf("No\n");
			continue;
		}
		if(pd(head)){
			dfs(head);
			if(flag) printf("Yes\n");
			else printf("No\n");
		}
		else{
			printf("No\n");
		}
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值