(DP,分组背包) I love sneakers! -- HDOJ

I love sneakers!

Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print “Impossible” if Iserlohn’s demands can’t be satisfied.

Sample Input

5 10000 3
1 4 6
2 5 7
3 4 99
1 55 77
2 44 66

Sample Output

255

Source
2009 Multi-University Training Contest 13 - Host by HIT

Recommend
gaojie

总结:
没遇到过这类问题,算是个模板吧
每个品牌分组里面至少选一个
状态转移方程为
dp[i][m] = max(max(dp[i][m],dp[i-1][m-w[j]]+v[j]),dp[i][m-w[j]]+v[j]);
i代表商标编号,m代表标价(花费的钱,可等价于重量),dp[i][m] 代表包含i种商标,花费为m的时候,获得的最大价值

值得注意的是dp数组的初始化,包含商标为零种的,即dp[0][] 这样的,都是初始化成零的,而其他需要由状态转移方程推到出来的,则初始化为无穷小

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int dp[12][10005];
int main(void)
{
  //  freopen("in.txt","r",stdin);
    int n,W,k;
    while(scanf("%d %d %d",&n,&W,&k) != EOF)
    {
        memset(dp,0,sizeof(dp));
        int w[120],v[120],id[120];
        for(int i=1; i<=k; ++i)
        for(int j=1; j<=W; ++j)
            dp[i][j] = -999999;

        for(int i=1; i<=n; ++i)
            scanf("%d %d %d",&id[i],&w[i],&v[i]);

        for(int i=1; i<=k; ++i)
        for(int j=1; j<=n; ++j)
        for(int m=W; m>=w[j]; --m)
        {
            if(id[j] == i)
            {
                dp[i][m] = max(max(dp[i][m],dp[i-1][m-w[j]]+v[j]),dp[i][m-w[j]]+v[j]);
            }
        }
        if(dp[k][W] < 0)
            cout <<"Impossible"<<endl;
        else
            cout << dp[k][W]<<endl;
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值