Cup
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1018 Accepted Submission(s): 361
Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?
The radius of the cup’s top and bottom circle is known, the cup’s height is also known.
Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.
Technical Specification
- T ≤ 20.
- 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
- r ≤ R.
- r, R, H, V are separated by ONE whitespace.
- There is NO empty line between two neighboring cases.
Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
Sample Input
1
100 100 100 3141562
Sample Output
99.999024
Source
The 4th Baidu Cup final
Recommend
lcy
总结:
圆台的体积:
(r*r + R*R + r*R)*PI*h/3; 用这个比较简便些
PI的定义 :acos(-1.0);
水的上底面的半径需要用待定的水的高度h来表示出来,这里稍微有点麻烦
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define PI acos(-1.0)
#define eps 0.00000001
using namespace std;
double r,R,H,V;
double getVol(double h)
{
double x = (h/H)*(R-r) + r;
return (x*x + x*r + r*r)*h*PI/3;
}
int main(void)
{
int ncase;
cin >> ncase;
while(ncase--)
{
scanf("%lf %lf %lf %lf",&r,&R,&H,&V);
double st=0,ed=H,mid;
while((ed-st) > eps)
{
mid = (st + ed) / 2;
// printf("A\n");
double v = getVol(mid);
if(v > V)
ed = mid;
else
st = mid;
}
printf("%.6lf\n",mid);
}
return 0;
}