hdu4310 Hero(简单贪心)

题目:

Hero

Time Limit:3000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output
Output one line for each test, indicates the minimum HP loss.

Sample Input
1
10 2
2
100 1
1 100

Sample Output
20
201

题意:
先输入一个n代表敌人的人数,接下来n行,每行第一个数据代表攻击(DFS),第二个数据代表血量(HP)。n个敌人打你,你掉的血量等于每个敌人的DFS值,每次你只能打一个敌人,你的血量无限,但是攻击只有1。请选择一个合适的攻击策略,将n个敌人打败,并且使自己掉的血最少。

思路:
如何使自己掉的血量尽可能的少呢?即将血量少攻击高的人优先打死,人少了受到的攻击小了,攻击高的也不能留着,那么按DFS/HP这个比率从大到小排序,将比率大的人优先杀死。

tip:
由于有除法的存在,要么使用double,要么将比值化为乘法比较,这样保证除法后结果没有对排序产生偏差。

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
const int maxn = 1000;

using namespace std;

struct node{
    double x, y;
}arr[maxn];

bool cmp(node a, node b){
    return (a.y/a.x<b.y/b.x);
}

int main(){
    int n;
    while(cin>>n){
        memset(arr,0,sizeof(arr));
        for(int i=0; i<n; i++)
            cin>>arr[i].x>>arr[i].y;

        sort(arr, arr+n, cmp);

        double ans = 0.0;
        for(int i=0; i<n; i++){
            ans += (arr[i].y * arr[i].x);
            for(int j=i+1; j<n; j++){
                ans += (arr[j].x * arr[i].y);
            }
        }

        cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值