poj1861 Network(kruskal求最小生成树)

Network
Time Limit: 1000MS Memory Limit: 30000K
     

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

题意:

有n个集线器,m条线路,求一条最短的路,并且输出这条最短路中权重最大的边,输出最短路边的数目,输出每一条边。


PS:这题样例是错的,害我看了几遍题目,最后百度了题解,看到说样例是错的。。。


思路:

虽然知道是求最小生成树,但是我用prim算法要如何输出最短路中的边呢?最后我看了题解,用了kruskal算法,算是初步接触吧。。

将边按权排序,那么我们在使用并查集的时候就存在一种贪心的思想,那么生成的是最小生成树,边的记录也很容易实现,在维护最小生成树的同时可以记录下新加入的边。由于含贪心思想,那么我们存最小生成树边的那个数组,最后存的边的权值就是最大的。


坑点:

注意sort排序的左右区间。


代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>


using namespace std;
int cnt;
const int maxn = 15000+10;

struct Edge
{
	int from, to, w;
};

int pre[maxn];
Edge edges[maxn], ans[maxn];

bool cmp(Edge a, Edge b){
	return a.w < b.w;
}

void init(int m){
	for(int i=1; i<=m; i++)
		pre[i] = i;
}

int Find(int x){
	if(pre[x]==x)
		return x;
	else
		return Find(pre[x]);
}

void unite(int x, int y, int w){
	int fx = Find(x);
	int fy = Find(y);
	if(fx!=fy){
		pre[fx] = fy;
		ans[cnt].from = x;
		ans[cnt].to = y;
		ans[cnt].w = w;
		cnt++;
	}
	return;
}

void kruskal(int m){
	init(m);
	for(int i=1; i<=m; i++)
		unite(edges[i].from, edges[i].to, edges[i].w);
	printf("%d\n", ans[cnt-1].w);
	printf("%d\n", cnt);
	for(int i=0; i<cnt; i++)
		printf("%d %d\n", ans[i].from, ans[i].to);
}

int main(){
	int n, m, a, b, w;
	while(scanf("%d%d", &n, &m)!=EOF){
		for(int i=1; i<=m; i++){
			scanf("%d%d%d", &edges[i].from, &edges[i].to, &edges[i].w);
		}
		sort(edges+1, edges+m+1, cmp);
		cnt = 0;
		kruskal(m);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值