poj2352 && hdu1541 Stars(树状数组)

Stars

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                          


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0

题意:

每颗星星都有一个level,这个level的大小决定于在他左边并且在它下边的星星数量有多少,最后输出每个level星星的数量


思路:

树状数组第一题。由于输入已经排序了,可以不需要考虑y值对答案的影响,因为输入中前边的y值小于等于后边的y值。所以我们只需要维护一个一维的树状数组,记录0到当前横坐标这个区间内星星的数量,那么这个数量就对应了这颗星星的level,再维护一个ans数组记录每个level的数量。


注意下标


代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int maxn = 32005;

int ans[maxn];
int sum[maxn];

int query(int pos){
	int cnt =0;
	while(pos>0){
		cnt += sum[pos];
		pos -= pos&-pos;
	}
	return cnt;
}

void update(int pos){
	while(pos<maxn){
		sum[pos]++; //直接加1即可
		pos += pos&-pos;
	}
	return;
}

int main(){
	int n, x, y;
	while(scanf("%d", &n)!=EOF){
		memset(ans, 0, sizeof(ans));
		memset(sum, 0, sizeof(sum));
		for(int i=0; i<n; i++){
			scanf("%d%d", &x, &y);
			ans[query(x+1)]++;
			update(x+1);
		}
		for(int i=0; i<n; i++)
			printf("%d\n", ans[i]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值